[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Re: [Fedora-xen] Dom0 kernels / 32bit PAE pv_ops dom0 kernel works now



On Mon, Aug 24, 2009 at 03:25:40PM -0400, Lester M. wrote:
> On Mon, Aug 17, 2009 at 11:09 AM, Pasi Kärkkäinen <pasik iki fi> wrote:
> 
> > On Fri, Aug 14, 2009 at 10:32:34PM +0100, M A Young wrote:
> > > Here is another update. (kernel-2.6.31-0.1.2.52.rc6.xendom0.fc12) at
> > > http://koji.fedoraproject.org/koji/taskinfo?taskID=1605651 and the
> > > repository http://fedorapeople.org/~myoung/dom0/<http://fedorapeople.org/%7Emyoung/dom0/>. I have had trouble
> > > getting x86_64 kernels built over the last week or so to boot, but this
> > > one does work. I haven't tried i686.
> > >
> >
> > Finally the 32bit PAE (i686) dom0 kernel crash problem has been fixed.
> >
> > Patch:
> >
> > http://git.kernel.org/?p=linux/kernel/git/jeremy/xen.git;a=commit;h=02ef83d1ed382d898bbb4a8ade9888e21fe33d1d
> >
> > I verified that patch fixes the problem.
> >
> > I'll try these RPMs soon.
> >
> > -- Pasi
> >
> > _______________________________________________
> > Fedora-virt mailing list
> > Fedora-virt redhat com
> > https://www.redhat.com/mailman/listinfo/fedora-virt
> 
> 
> 
> Pasi / M.A. Young,
> 
> Can these new rpms be used directly on a fedora 11 system? Or do I have to
> upgrade to rawhide to use these?
> 
> I ask this because I tried to install and test these rpms, and I got
> depsolving errors having to do with the version of rpmlib, and a few other
> packages. Here is the exact output:
> 
> $ rpm -Uvh kernel-*
> error: Failed dependencies:
>     rpmlib(PayloadIsXz) <= 5.2-1 is needed by
> kernel-firmware-2.6.31-0.1.2.52.rc6.xendom0.fc12.noarch
>     rpmlib(PayloadIsXz) <= 5.2-1 is needed by
> kernel-headers-2.6.31-0.1.2.52.rc6.xendom0.fc12.i686
>     grubby >= 7.0.2-1 is needed by
> kernel-PAE-2.6.31-0.1.2.52.rc6.xendom0.fc12.i686
>     rpmlib(PayloadIsXz) <= 5.2-1 is needed by
> kernel-PAE-2.6.31-0.1.2.52.rc6.xendom0.fc12.i686
>     rpmlib(PayloadIsXz) <= 5.2-1 is needed by
> kernel-PAE-devel-2.6.31-0.1.2.52.rc6.xendom0.fc12.i686
>     kernel-drm-nouveau = 12 is needed by (installed)
> xorg-x11-drv-nouveau-1:0.0.12-40.20090528git0c17b87.fc11.i586
>     kernel-uname-r = 2.6.29.5-191.fc11.i686.PAE is needed by (installed)
> kmod-iscsitarget-2.6.29.5-191.fc11.i686.PAE-1:0.4.17-2.fc11.15.i686
>     kernel-uname-r = 2.6.29.6-213.fc11.i686.PAE is needed by (installed)
> kmod-iscsitarget-2.6.29.6-213.fc11.i686.PAE-1:0.4.17-2.fc11.16.i686
> 
> 
> Please advise. I am not really ready to go 100% rawhide at this time. :-(

Use the force!

rpm -Uvh --force --nodeps kernel-*

Should work.. afaik. You also need newer libvirt from updates-testing, at
least if you run Xen 3.4.1 (from rawhide).

-- Pasi


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]