[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Re: [Fedora-xen] Dom0 kernels / 32bit PAE pv_ops dom0 kernel works now



On Wed, 26 Aug 2009, Lester M. wrote:


# rpm -Uvh kernel-*
error: Failed dependencies:
    rpmlib(PayloadIsXz) <= 5.2-1 is needed by
kernel-firmware-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.noarch
...
That looks like you need to update rpm. rpm-4.7.1-1.fc11 should work.


# ls kernel-*
kernel-firmware-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.noarch.rpm
kernel-headers-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.i686.rpm
kernel-PAE-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.i686.rpm
kernel-PAE-devel-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.i686.rpm


Then, I proceeded to heed Michael's advisory:


rpm -ivh --nodeps kernel-*

rpm -ivh kernel-PAE-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.i686.rpm kernel-firmware-2.6.31-0.1.2.58.rc7.git1.xendom0.fc12.noarch.rpm
should work. As you have discovered you can only have one kernel-headers package at a time. Note though that I haven't got the i686 version of the kernel to boot recently.

	Michael Young

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]