[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [fedora-virt] Invalid configuration unexpected EOF when using -x



Try single quotes or use back slashes to escape the ampersands
  --jim

-----Original Message-----
From: fedora-virt-bounces redhat com [mailto:fedora-virt-bounces redhat com] On Behalf Of Ray Van Dolson
Sent: Tuesday, July 07, 2009 11:09 AM
To: fedora-virt redhat com
Subject: [fedora-virt] Invalid configuration unexpected EOF when using -x

Hi all;

Trying to deploy a CentOS 5 domU under RHEL 5.3 64-bit and am running
into the following error:

  virDomainCreateLinux() failed POST operation failed: (xend.err 'Invalid configuration unexpected EOF')
  Domain installation may not have been
   successful.  If it was, you can restart your domain
   by running 'virsh start cobbler'; otherwise, please
   restart your installation.
  Tue, 07 Jul 2009 10:59:38 ERROR    virDomainCreateLinux() failed POST operation failed: (xend.err 'Invalid configuration unexpected EOF')
  Traceback (most recent call last):
    File "/usr/sbin/virt-install", line 560, in ?
      main()
    File "/usr/sbin/virt-install", line 492, in main
      dom = guest.start_install(conscb, progresscb, wait=(not wait))
    File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install
      return self._do_install(consolecb, meter, wait)
    File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 843, in _do_install
      self.domain = self.conn.createLinux(install_xml, 0)
    File "/usr/lib64/python2.4/site-packages/libvirt.py", line 573, in createLinux
      if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
  libvirtError: virDomainCreateLinux() failed POST operation failed: (xend.err 'Invalid configuration unexpected EOF')

This only seems to happen when I pass my virt-install command as
follows:

  virt-install --name cobbler --ram 1024 --file=/ludlow2/cobbler.img \
    --vnc --vcpus=2 --nonsparse -w bridge:xenbr0 -l \
    http://yummie.esri.com/mrepo/centos5-x86_64/os/ \
    -x "updates=http://yummie.esri.com/updates/updates-el5.1.img ks=http://yummie/ks/ks.php?arch=x86_64&distro=centos&major=5&minor=2"; \
    --os-type=linux -d

The error appears to be triggered by my kickstart URL location which
includes ampersands and such -- despite the fact that I am include
quotes around the entire argument.

The debug output indicates that the XML is being written with the
ampersand changed into &.

If I change my kickstart location to a URL without the GET variables,
everything works fine.

Bug?  Expected behavior?  Workaround?  Perhaps this is an issue in
virt-install and wouldn't happen if I crafted the XML file myself?

python-virtinst-0.300.2-12.el5

Thanks,
Ray

_______________________________________________
Fedora-virt mailing list
Fedora-virt redhat com
https://www.redhat.com/mailman/listinfo/fedora-virt


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]