[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Invalid configuration unexpected EOF when using -x



Ray Van Dolson wrote:
> On Tue, Jul 07, 2009 at 11:52:41AM -0700, Cole Robinson wrote:
>> Ray Van Dolson wrote:
>>>   virt-install --name cobbler --ram 1024 --file=/ludlow2/cobbler.img \
>>>     --vnc --vcpus=2 --nonsparse -w bridge:xenbr0 -l \
>>>     http://yummie.esri.com/mrepo/centos5-x86_64/os/ \
>>>     -x "updates=http://yummie.esri.com/updates/updates-el5.1.img ks=http://yummie/ks/ks.php?arch=x86_64&distro=centos&major=5&minor=2"; \
>>>     --os-type=linux -d
>>>
>>> The error appears to be triggered by my kickstart URL location which
>>> includes ampersands and such -- despite the fact that I am include
>>> quotes around the entire argument.
>>>
>>> The debug output indicates that the XML is being written with the
>>> ampersand changed into &.
>>>
>>> If I change my kickstart location to a URL without the GET variables,
>>> everything works fine.
>>>
>>> Bug?  Expected behavior?  Workaround?  Perhaps this is an issue in
>>> virt-install and wouldn't happen if I crafted the XML file myself?
>>>
>>> python-virtinst-0.300.2-12.el5
>>>
>>> Thanks,
>>> Ray
>>>
>> Pretty sure we fixed bugs in this area in 5.3: run the command with
>> --debug and see if the generated output has & in it.
> 
> Yep, did run with --debug (-d) and the XML output has & in it.  I
> haven't yet tried the single quote option as a workaround however.
> 

Argh, sorry, I didn't read your first message clearly.

> Here is the cmdline generated (per debug output):
> 
>   <cmdline>updates=http://yummie.esri.com/updates/updates-el5.1.img ks=http://yummie/ks/ks.php?arch=x86_64&amp;distro=centos&amp;major=5&amp;minor=2 method=http://yummie.esri.com/mrepo/centos5-x86_64/os/</cmdline>
> 
>> I think in this case it is actually xend that is choking, which I don't
>> know any workaround for.
>>
> 
> So xend should be able to handle &amp; ?  Or, if my <cmdline> had &
> instead of &amp; would xend be able to handle that?
> 

The & -> &amp; replacement is necessary for XML, so it's only needed for
talking to libvirt. That '&amp;' should be getting converted back to
plain & when passed off to xen. I think xen is just choking on the plain
'&'.

Try running the virtinst command with LIBVIRT_DEBUG=1 and see if there
is a generated sexpr printed (like you get with xm list --long).

- Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]