[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] pv_ops dom0 kernel RPM, configuration & setup help anyone?



On Wed, Jul 8, 2009 at 6:32 AM, Pasi Kärkkäinen <pasik iki fi> wrote:
On Wed, Jul 08, 2009 at 01:22:30AM +0000, Lester M. wrote:
> I downloaded the following rpms from M. Youngs fedora-people page. (
> http://fedorapeople.org/~myoung/dom0/)
>
> kernel-firmware-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.noarch.rpm
> kernel-headers-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i586.rpm
> kernel-PAE-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.rpm
> kernel-PAE-devel-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.rpm
>
> I am interested in *Testing* under the understanding that this is in beta.
> My question is, after installation of the rpms, what configuration (config
> files, grub, et al) is needed to successfully boot into dom0? I recall there
> were a few hoops to jump through to get a working dom0.
>
> I also have compiled the xen3.4 tools (hg clone
> http://xenbits.xensource.com/xen-3.4-testing.hg)
>

You could also get the xen 3.4.0 hypervisor/tools RPMs from rawhide..
although from that xen-3.4-testing.hg repo you'll get 3.4.1-rc6 atm with a
lot of fixes after 3.4.0.

(I think the plan was to upload xen 3.4.1 to F11, later when it has been released
upstream.)

> Could somebody please post a workflow for getting this running? I have
> installed the rpms and I am now like "Now what?" :-P

Modify your grub.conf to boot the xen hypervisor, add line /etc/fstab to
mount xenfs and hmm.. I guess that's it :)

See: http://wiki.xensource.com/xenwiki/XenParavirtOps
Pasting from that page:

Working example grub.conf with VGA text console:

title        Xen 3.4-unstable, kernel 2.6.30-rc3-tip
root         (hd0,0)
kernel        /boot/xen-3.4-unstable.gz dom0_mem=512M
module        /boot/vmlinuz-2.6.30-rc3-tip root=/dev/sda1 ro
module        /boot/initrd.img-2.6.30-rc3-tip


-- Pasi

Thank you Pasi,

Here is what my grub.conf entry looks like (with the xen-3.4.1 tools compiled,) after you install all 4 rpms from myoung's fedorapeople page: (http://fedorapeople.org/~myoung/dom0/)

title Fedora (2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE)
    root (hd0,0)
    kernel /vmlinuz-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE ro root=/dev/mapper/vg01-lv_root rhgb quiet nomodeset
    initrd /initrd-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE.img


When you compile and install xen-3.4.1 the following is created in /boot:

-rw-r--r--. 1 root root  498660 2009-07-07 17:08 xen-3.4.1-rc6.gz
lrwxrwxrwx. 1 root root      16 2009-07-07 17:08 xen-3.4.gz -> xen-3.4.1-rc6.gz
lrwxrwxrwx. 1 root root      16 2009-07-07 17:08 xen-3.gz -> xen-3.4.1-rc6.gz
lrwxrwxrwx. 1 root root      16 2009-07-07 17:08 xen.gz -> xen-3.4.1-rc6.gz


I modified it per the pvops wiki page: (http://wiki.xensource.com/xenwiki/XenParavirtOps)

title Fedora (2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE)
    root (hd0,0)
    kernel /xen-3.4.1-rc6.gz dom0_mem=512M
    module /vmlinuz-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE ro root=/dev/mapper/vg01-lv_root rhgb quiet
    module /initrd-2.6.31-0.1.2.37.rc1.git5.xendom0.fc12.i686.PAE.img



This is what is in my /etc/fstab:

none                    /proc/xen               xenfs   defaults        0 0


So now I boot. When I boot the system the dom0 starts up instantly...., to the point where it says "scrubbing free ram" then the screen goes blank and all system activity ceases.

Has anyone tried these rpms? I am not sure if i can scream out "bug!" "bug!" because I cannot find anyone that has actually installed these rpms as part of a deployment process, (a workflow, a howto, a "step by step" edit "this" or edit "that".) so I am not sure if it is that I am missing a config parameter or not.

My hardware:

Lenovo thinkpad T60 (Centrino Duo processor)
ATI Radeon X1300 card
(Its an "oldie" but on RHEL 5.3 it runs xen very very well.)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]