[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Can't use network in guests



> On Tue, Jul 28, 2009 at 4:13 PM, Mark McLoughlin<markmc redhat com> wrote:
> >>    <interface type='bridge'>
> >>      <mac address='54:52:00:49:73:9a'/>
> >>      <source bridge='br0'/>
> >>      <target dev='vnet%d'/>
> >
> > Try deleting this line

> I tried removing the line with virsh edit, but restarting the VM with
> virsh start leads to the same error. I double checked and the line
> appeared again, I've no idea how it got there again...

I've just gone through similar situations and now have everything
working like I want.  One of many problems I had was the one above
(and I'm not sure which thing I did fixed it.)
So here's some ideas:

1. Make sure you aren't using NetworkManager.  It seems to do unexpected
   things automatically, and according to
	  http://wiki.libvirt.org/page/Networking#Fedora.2FRHEL_Bridging
   is doesn't support bridging as of F9.  The instructions at that URL
   pretty much gave me everything I needed to get things going.

2. When I set my interface as you have (mac address and soruce bridge only)
   it adds a target dev=vnet0 automatically.  And this works.

3. You might need to update some packages.  On the client I was unable
   to make NIS work until I updated the ypbind package.

Good luck.

Rich




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]