[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Virtualization Test Day



Hey,
	Okay, I think we made heaps of progress today. To give you an idea of
what went on today, see below for the list of bugs that were filed
during the test day.

	You can also take a peak at the wiki:

  https://fedoraproject.org/wiki/Test_Day:2009-05-07_Virtualization

	for results from people's testing. I especially like the Guest Installs
page:

  https://fedoraproject.org/wiki/Test_Day:2009-05-07_Virtualization_Guest_Installs

	Thanks to everyone who got stuck in, but I thought it would be nice to
credit the people who filed bugs ... so, from a quick query:

      7 clalance
      6 markmc
      5 berrange
      4 mtosatti
      4 jlaska
      3 paniraja_km
      3 ondrejj
      3 charles_rose
      2 Rainer.Koenig
      2 lili
      2 apevec
      2 mike.hinz
      1 wwoods
      1 tjb
      1 ravishankar.srinivasan
      1 paul.moore
      1 esandeen
      1 daire.byrne
      1 aron

	No doubt the testing will continue and there'll be a bunch more bugs in
my inbox in the morning :-)

Thanks again,
Mark. 

Device assignment:

  https://bugzilla.redhat.com/499614
    System locks up when booting with "intel_iommu=on"

    A report from Fujitsu that intel_iommu=on locks up one of their
    machines at boot. Likely a BIOS bug.

  https://bugzilla.redhat.com/499637
    IOMMU: no free domain ids

    Looks like a DMAR domain ID leak in the kernel.

  https://bugzilla.redhat.com/499261
    KVM PCI device assignment fails with
    "assigned_dev_register_regions: Error: Couldn't mmap 0xffa40000!"

    This turned out to be libvirt interpreting managed=yes
    incorrectly.

  https://bugzilla.redhat.com/499678
    libvirt should be able to reset a PCI function even if it causes
    other unused devices/functions to be reset

    libvirt's PCI reset logic needs work. Not trivial.

  https://bugzilla.redhat.com/499561
    libvirt does not automatically re-attach an assigned device in the
    host after guest shutdown

    Should be fixable.

  https://bugzilla.redhat.com/499386
    libvirt's qemu driver interprets the <hostdev> "managed"
    attribute incorrectly

    libvirt was treating managed=yes as managed=no.

  https://bugzilla.redhat.com/499708
    SELinux blocks libvirtd sysfs writes for
    virNodeDeviceDettach()/Reattach()/Reset()

    Fixed by latest selinux-policy.

  https://bugzilla.redhat.com/499259
    svirt denials breaks KVM PCI device assignment

    Not trival to fix correctly.

  https://bugzilla.redhat.com/499267
    Assigning a PCI device using virt-manager/virt-install fails

    virtinst's code to detach/reset the device before starting the
    guest was broken. Cole cooked up a patch to fix it.

  https://bugzilla.redhat.com/499352
    Re-enable CONFIG_DMAR_DEFAULT_ON

    Somewhere along the way, DMAR got disabled by default. Even though
    the original issue was fixed, it didn't get re-enabled.

VNC Authentication:

  https://bugzilla.redhat.com/499589
    virt-manager console widget doesn't know how to collect a 'username'
    for authentication with VNC

  https://bugzilla.redhat.com/499594
    virt-viewer doesn't know how to provide a username/password to
    libvirt connections

  https://bugzilla.redhat.com/499595
    virt-viewer mixes up password and username credentials for VNC

qemu:

  https://bugzilla.redhat.com/499697
    failure to install new kvm packages on FC10 -> FC11 DVD upgrade

  https://bugzilla.redhat.com/499542
    Graphics crashes when vmware video card is selected

  https://bugzilla.redhat.com/499547
    After OS install, reboot causes the guest to shutdown

  https://bugzilla.redhat.com/499596
    32 bit KVM guest hangs enabling NX protection; booting with -cpu
    qemu32 works

  https://bugzilla.redhat.com/499601
    KVM guest fails to boot with if=virtio; works with if=ide

  https://bugzilla.redhat.com/499586
    Installation of guest using Network boot(PXE) is failing

  https://bugzilla.redhat.com/499666
    Reboot fails when using qemu -kernel

  https://bugzilla.redhat.com/499712
    [PATCH] qemu-kvm: avoid harmless unhandled wrmsr 0xc0010117 messages

libvirt:

  https://bugzilla.redhat.com/499584
    info balloon is repeated in qemu log once per second

  https://bugzilla.redhat.com/499633
    libnuma: Warning: /sys not mounted or invalid

  https://bugzilla.redhat.com/499698
    'virsh destroy' destroys multiple VMs

  https://bugzilla.redhat.com/499704
    VM migration fails with "TCP migration is not supported with this
    QEMU binary"

  https://bugzilla.redhat.com/499750
    libvirt VM migration fails with "error: Unknown failure"

SELinux/sVirt related:

  https://bugzilla.redhat.com/499536
    libvirtd AVC denials - uml backend writing to /root/

  https://bugzilla.redhat.com/499551
    AVC denial from virsh dominfo - libvirtd (virtd_t) "getattr"
    svirt_t.

  https://bugzilla.redhat.com/499569
    Guest with source-less cdrom fails to start :: Failed to set
    security label

  https://bugzilla.redhat.com/499638
    SELinux is preventing libvirtd (virtd_t) "getattr"
    unconfined_notrans_t.

  https://bugzilla.redhat.com/499711
    svirt error when starting guest - SELinuxSetSecurityLabel: unable
    to set security context 'system_u:system_r:svirt_t:s0:c152,c660':
    Invalid argument.

Xen DomU:

  https://bugzilla.redhat.com/499611
    Hotplugging vcpus to an F-11 64-bit Xen domU doesn't work

  https://bugzilla.redhat.com/499587
    Cannot balloon a F-11 Xen domU guest above the initial starting
    memory

  https://bugzilla.redhat.com/499592
     F-11 Xen 64-bit domU cannot be started with > 2047MB of memory

  https://bugzilla.redhat.com/499621
    F-11 Xen 64-bit domU stack traces when unmounting a disk

  https://bugzilla.redhat.com/499630
    F-11 Xen 64-bit domU hangs when trying to format a fake 5TB disk

  https://bugzilla.redhat.com/499644
    F-11 Xen 64-bit domU does not give memory back to the dom0

  https://bugzilla.redhat.com/499648
    F-11 Xen 64-bit domU cannot crashdump

virtinst:

  https://bugzilla.redhat.com/499555
    virtinst: Debian Lenny cannot handle virtio NIC

  https://bugzilla.redhat.com/499654
    failure to add more than 16 virtio-blk devices in virt-manager

  https://bugzilla.redhat.com/499718
    virtinst incorrectly guesses os variant from F11Preview .treeinfo

virt-manager:

  https://bugzilla.redhat.com/499656
    virt-manager Scaling->Always - scales the guest screen up but not
    down.

  https://bugzilla.redhat.com/499664
    inconsistency between reported device names / guest device names in
    virt-manager

  https://bugzilla.redhat.com/499665
    When window focus set to click - <ctrl><alt> grabs pointer even
    when virt-manager isn't focused

  https://bugzilla.redhat.com/499669
    hot-removing in-use virtio-blk device in virt-manager should fail

  https://bugzilla.redhat.com/499685
    RFE - include virt type in virt-manager Guest->Details tab


  https://bugzilla.redhat.com/499703
    virt-manager should run stats refresh operation in a background
    thread per connection

anaconda:

  https://bugzilla.redhat.com/499563
    anaconda in a KVM guest only occupies 800x600 of a 1024x768 screen

  https://bugzilla.redhat.com/499580
    F11Preview: anaconda writes ifcfg-eth0 with unquoted NAME parameter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]