[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [fedora-virt] Using the virtio drivers in Windows XP setup



Hi Richard,

The txtsetup.oem file you mentioned was not with your email, I am not sure if you forgot or the mailing list eats attachments.

Perhaps you have a URL to the file? It also sounds like a small script would make it easier for everyone to install the drivers.

Regards,
Anand

On Fri, Oct 23, 2009 at 2:14 PM, Richard Hughes <hughsient gmail com> wrote:
This may be useful to somebody. To use the virtio drivers in windows
XP setup, you have to do the following:

* create a 1.44Mb image file
* mount it by loopback
* format it with vfat
* copy the Install/Xp/x86/viostor.sys, Install/Xp/x86/wnet.inf, and
the attached txtsetup.oem file to the root of the mounted image
* umount the loop device
* attach the floppy image as a floppy storage element in the VM's details pane
* boot the VM
* remember to press F6 when booting the windows xp setup and select
the VirtoIO device.

The txtsetup.oem was just cobbled together after reading various
sources online, and hacking values out of the supplied inf file.

Richard.

p.s. I'm still unable to install XP using ide, scsi or virtio drivers
as it gives the message "Setup was unable to format the partition. The
disk maybe damaged." -- any ideas welcome.

_______________________________________________
Fedora-virt mailing list
Fedora-virt redhat com
https://www.redhat.com/mailman/listinfo/fedora-virt



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]