[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[fedora-virt] Do I have to bugzilla for rpm requirements of virt-df?



Running virt-df on a F11 x86_64 system with fedora-virt-preview enabled I get this:

[root virtfed ~]# virt-df prova2
Filesystem                           1K-blocks       Used  Available  Use%
open_guest: no libvirt support (install Sys::Virt, XML::XPath and XML::XPath::XMLParser) at /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Sys/Guestfs/Lib.pm line 148.

perl-Sys-Virt is already installed while I'm missing the perl-XML-XPath and related dependencies...

After I do a
yum install perl-XML-XPath
that makes automatically:
Installing:
 perl-XML-XPath                        noarch                1.13-8.fc11                  fedora                  85 k
Installing for dependencies:
 perl-Compress-Raw-Zlib                x86_64                2.008-73.fc11                updates                 81 k
 perl-Compress-Zlib                    x86_64                2.008-73.fc11                updates                 37 k
 perl-HTML-Parser                      x86_64                3.60-1.fc11                  updates                121 k
 perl-HTML-Tagset                      noarch                3.20-2.fc11                  fedora                  17 k
 perl-IO-Compress-Base                 x86_64                2.008-73.fc11                updates                 62 k
 perl-IO-Compress-Zlib                 x86_64                2.008-73.fc11                updates                143 k
 perl-URI                              noarch                1.37-2.fc11                  fedora                 121 k
 perl-XML-Parser                       x86_64                2.36-4.fc11                  fedora                 298 k
 perl-libwww-perl                      noarch                5.825-2.fc11                 fedora                 397 k

I'm able to run virt-df (though a bit slow to output the results):

[root virtfed ~]# virt-df prova2
Filesystem                           1K-blocks       Used  Available  Use%
prova2:/dev/sda1                        198337      21627     166470 16.1%
prova2:/dev/vg_prova2/lv_root          3918752    3162200     557488 85.8%

Question: so virt-df should have as dependency perl-XML-XPath, otherwise is unusable, correct? Or could it stay without perl-XML-XPath connecting to VMs in other ways?

As I'm on f11+fedora-virt-preview repo I donna if this is a non-problem and instead it is ok on F12.
it seems that both virt-df and perl-XML-XPath rpms are form f11 repos so probably I have to bugzilla for F11?

Gianluca


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]