[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Guest shutdown problems



I have noticed that restarting xend fixes the states. Does that give anyone any ideas?

Christian Axelsson wrote:
Hello

I have a problem shutting down xen guests. Using xm shutdown guests get shut down but gets stuck in state '---s-d' or sometimes '------'. When trying to clone a domain when in this state (my original purpose of the whole operation) I'll get the error:

  [root hydra virtinst--devel]# ./virt-clone -o minimal -n new_img -f
    /var/lib/xen/images/new_img.img
  ERROR:  virDomainGetXMLDesc() failed failed Xen syscall
  xenDaemonDomainDumpXMLByID failed to find this domain -490299505

The same errors occurs when for example trying to attach to the console using virsh.

I have tried to use 'xm destroy' to kill the guest the hard way but it has no effect - the state remains unchanged. I have also tried this on a few different guest installations with the same result. A thing worth noting is that the output from 'xm list --long' differs, I've attached the out put pre boot, after boot and after shutdown. Note how all the devices in the guests are missing after shutdown.

Both the hosts and the guests are fedora 8 installations.

Regards,
Christian Axelsson
smiler lanil mine nu
------------------------------------------------------------------------

--
Fedora-xen mailing list
Fedora-xen redhat com
https://www.redhat.com/mailman/listinfo/fedora-xen


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]