[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [Fedora-xen] Newby Help



uname -a
Linux cloudy 2.6.20-1.3002.fc6xen #1 SMP Mon Aug 13 14:21:21 EDT 2007
x86_64 x86_64 x86_64 GNU/Linux

FWIW, the file that Anaconda is complaining about is
http://download.fedora.redhat.com/pub/fedora/linux/core/6/x86_64/os//ima
ges/stage2.img , which seems to be sitting there as advertised, although
my link is pretty slow; could it be timing out over the transfer?

If understand the flags:

[wcoole cloudy ~/Desktop]$ egrep "svm|vmx" /proc/cpuinfo
[wcoole cloudy ~/Desktop]$

I cannot run Fully-virtualized guests, which seems to imply that I have
to run a para-virt guest.

I was imagining that it would be simplest to use a file (on the host
filesystem) as the filesystem for the guest, but I've probably mangled
the configuration.  I'm using this command to start it:

sudo /usr/sbin/xm create -c football.cfg 

It seems likely that I haven't got the config set right; here's
football.cfg:

cat football.cfg
kernel = "/boot/vmlinuz-2.6.20-1.3002.fc6xen"
memory = 256
name = "football"
vif = [ '' ]
dhcp = "dhcp"
disk = ['file://xen/fedora/football.img,sda1,w',
'file://xen/fedora/football.swap,sda2,w']
root = "/dev/sda1 ro"

I got the img, swap, and cfg files from the tarball at
http://jailtime.org/download:fedora:fc6 , but copied and hacked them
without really knowing what I was doing.  I'm not fixated on any
particular approach, just trying to do the easy thing to get started so
I can fool myself into thinking I know what I'm doing.

Thanks
Walter


-----Original Message-----
From: Mark Nielsen [mailto:mnielsen redhat com] 
Sent: Tuesday, March 25, 2008 6:01 PM
To: Walter Coole
Cc: fedora-xen redhat com
Subject: Re: [Fedora-xen] Newby Help

Hi Walter, sorry to hear you're having trouble.

Walter Coole wrote:
>
> I'm having trouble getting Xen up on Fedora 6. Following the 
> instructions at http://fedoraproject.org/wiki/FedoraXenQuickstartFC6 ,

> I've got xend running, but haven't gotten a viable image running.
>
> I tried (per the above) virt-manager. I guessed that 
> http://download.fedora.redhat.com/pub/fedora/linux/core/6/x86_64/os/ 
> was a suitable install tree, but when the installer (Anaconda, I 
> guess) gets to some point (it varies with each attempt) it stalls, 
> sometimes complaining about not getting a file.
>
What type of system are you running this on? Is it 32 or 64 bit? What 
kernel are you running? (uname -a)
>
> I also tried xm, but haven't figured out how to deal with the error:
>
> Cannot open root device "sda1"
>
um... what disk are you presenting to your guest? Installing from the 
http:// tree would indicate that you're installing a para-virt guest, 
but it's looking for sda1. Typically the disk inside the guest is known 
as xvda, which makes me wonder if you're presenting sda1 to the guest as

its root. Is that the same root disk that your host is using?
>
> Virsh throws a different error:
>
> Domain not found: xenUnifiedDomainLookupByName
>
yeah, hate to say this, but the xen logs can be very confusing and hard 
to read until you get used to the various errors and what they *really* 
mean sometimes.
>
> I'm befuddled by having tried several different sources, each of which

> said "it's soooo easy", but failing to provide sufficient information 
> to get me past these issues, so I'd be grateful if someone could point

> me to instructions geared to the meanest understanding.
>
Yep, it actually is relatively easy, but that is assuming all the 
requirements are met. Those are usually the hardest parts to figure out!

Mark

> Walter
>
>
------------------------------------------------------------------------
>
> --
> Fedora-xen mailing list
> Fedora-xen redhat com
> https://www.redhat.com/mailman/listinfo/fedora-xen
>   


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]