[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Re: [Xen-devel] Re: Errors when build 2.6.31-rc8



I lost one thing. After backport xen-libs-3.4.1 would be updated, hence libvirt might
require another changes as well.
B.

--- On Mon, 9/7/09, Boris Derzhavets <bderzhavets yahoo com> wrote:

From: Boris Derzhavets <bderzhavets yahoo com>
Subject: Re: [Fedora-xen] Re: [Xen-devel] Re: Errors when build 2.6.31-rc8
To: "Pasi Kärkkäinen" <pasik iki fi>
Cc: "Xen-devel" <xen-devel lists xensource com>, fedora-xen redhat com
Date: Monday, September 7, 2009, 3:25 AM

Pasi,

I was trying to load the most recent 2.6.31-rc8 under Xen 3.4.1 ( via src.rpm) on F12
rawhide and got stack trace. Jeremy is saying that rc8 works ok under Xen Unstable.
But, Libvirt 0.7.0-6 would obviously have dependencies  on xen-3.4.1 packages.
If i will port Xen 3.5 directly to F12 (F11) it might work with rc8, however Libvirt 0.7.0-6 will be most probably lost again. Libvirt 0.7.0-6 has been built for 3.4.1 Hypervisor ( in my understanding) . That's why i wrote if Xen 3.5 can load rc8, the easiest way to fix
issue is to backport required Xen 3.5 CSs to xen-3.4.1-X(?).src.rpm  and get it resolved before F12 November's release.

Boris

--- On Mon, 9/7/09, Pasi Kärkkäinen <pasik iki fi> wrote:

From: Pasi Kärkkäinen <pasik iki fi>
Subject: Re: [Fedora-xen] Re: [Xen-devel] Re: Errors when build 2.6.31-rc8
To: "Boris Derzhavets" <bderzhavets yahoo com>
Cc: "Xen-devel" <xen-devel lists xensource com>, fedora-xen redhat com
Date: Monday, September 7, 2009, 2:57 AM

On Sun, Sep 06, 2009 at 09:49:41PM -0700, Boris Derzhavets wrote:
> As far as Xen 3.5 tarball will be officially released  kernel supporting Dom0 should be
> JF's pvops kernel. When  xen-3.5.0-X.src.rpm and updated libvirt ( next preview)
> will become available via F13 rawhide , F12 & F13 rawhide would be ready to go
> in text mode as 3.5 Xen Hosts with virt-install&virt-manager available via VNC
> connections.  Why wait until Upstream merge ?
>

Uhm.. sorry I'm a bit confused. If I understood correctly you have a
call trace on your pv_ops dom0 kernel?

Does that only happen with Xen 3.4.1 or what's the problem?

-- Pasi

> Boris
>
> --- On Sun, 9/6/09, Pasi Kärkkäinen <pasik iki fi> wrote:
>
> From: Pasi Kärkkäinen <pasik iki fi>
> Subject: Re: [Fedora-xen] Re: [Xen-devel] Re: Errors when build 2.6.31-rc8
> To: "Mr. Teo En Ming (Zhang Enming)" <enming teo asiasoftsea net>
> Cc: bderzhavets yahoo com, "Xen-devel" <xen-devel lists xensource com>, "Jeremy Fitzhardinge" <jeremy goop org>, fedora-xen redhat com
> Date: Sunday, September 6, 2009, 2:37 PM
>
> On Mon, Sep 07, 2009 at 01:10:14AM +0800, Mr. Teo En Ming (Zhang Enming) wrote:
> > On 09/07/2009 01:04 AM, Boris Derzhavets wrote:
> > >I believe, that some set of CSs from Xen 3.5 has to be included as
> > >patches into
> > >xen-3.4.1-3.src.rpm, in case if it causes by 3.4.1 Hypervisor.
> > >Otherwise  , F12 release in November won't have suitable Dom0 kernel
> > >again.
> > >I would guess 2.6.31-rc6 at best.
> > >
> > >Boris.
> > >
> > >--- On *Sun, 9/6/09, Boris Derzhavets /<bderzhavets yahoo com>/* wrote:
> > >
> > >
> > >    From: Boris Derzhavets <bderzhavets yahoo com>
> > >    Subject: [Fedora-xen] Re: [Xen-devel] Re: Errors when build 2.6.31-rc8
> > >    To: "Jeremy Fitzhardinge" <jeremy goop org>
> > >    Cc: "Xen-devel" <xen-devel lists xensource com>, fedora-xen redhat com
> > >    Date: Sunday, September 6, 2009, 12:56 PM
> > >
> > >    Attempt to load 2.6-31-rc8 under Xen 3.4.1 , installed via
> > >    xen-3.4.1-3.src.rpm along with
> > >    libvirt(rawhide) , on top F12 rawhide. yum update gcc,glibc,kernel
> > >    had been run.
> > >
> > >    Call trace:
> > >
> > >    usb_hc_died + .....
> > >    usb_add_hcd +.....
> > >    usb_hcd_pci_probe + ....
> > >    do_work_for_cpu + .....
> > >    local_pci_probe + ...
> > >    do_work_for_cpu +.....
> > >    kthread +.....
> > >    child_rip+....
> > >    restore_args + .....
> > >    child_rip + .....
> > >    Code : .   .   .   .
> > >    .  .  .   .
> > >
> > >    RIP [<ffff...c7>] usb_kick_khubd + 0x10/0x25
> > >    RSP < ffff ... e0>
> > >    CR2: 00000...098
> > >
> > >    ---[ end trace 8219......]----
> > >
> > >    uhci_hcd 0000:00:1a:0 host controller process error, something bad
> > >    happened !
> > >    uhci_hcd 0000:00:1a:0 host controller halted , very bad
> > >    uhci_hcd 0000:00:1a:0  HC died, cleaning up
> > >
> > >    2.6.31-rc6 loads fine in same environment under Xen 3.4.1 on top
> > >    of  F12 rawhide
> > >
> > >    Boris,
> > >
> > >
> > >
> > >   
> > I thought Fedora will no longer have dom 0 kernel?
> >
>
> http://fedoraproject.org/wiki/Features/XenPvopsDom0
>
> "Dom0 status: awaiting upstream kernel support"
>
> -- Pasi
>
>
> _______________________________________________
> Xen-devel mailing list
> Xen-devel lists xensource com
> http://lists.xensource.com/xen-devel
>
>
>
>       

_______________________________________________
Xen-devel mailing list
Xen-devel lists xensource com
http://lists.xensource.com/xen-devel


-----Inline Attachment Follows-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]