[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] [Xen-devel] [ANNOUNCE] Xen 3.3.2 and 3.4.1 released / 3.4.1-3 rpm available from koji / F12 problem with pygrub



On Mon, Sep 14, 2009 at 08:55:23AM +0200, Gerd Hoffmann wrote:
>   Hi,
> 
> >However, If I do 'rpmbuild --bb xen.spec' for xen-3.4.1-3.fc12.src.rpm and 
> >install
> >the rebuilt rpms, pygrub works just fine!
> >
> >So is there some lib missing from the build requirements or?
> 
> e2fsprogs-devel most likely.
> 

Yeah, it seems I have e2fsprogs-devel installed on my testbox. So that
explains the difference.

The attached xen.spec patch fixes this issue. Please add it for xen-3.4.1-4.

-- Pasi

--- xen.spec.orig	2009-09-14 19:14:57.000000000 +0300
+++ xen.spec	2009-09-14 19:16:06.000000000 +0300
@@ -62,6 +62,8 @@
 BuildRequires: gettext
 BuildRequires: gnutls-devel
 BuildRequires: openssl-devel
+# For pygrub EXT4 support
+BuildRequires: e2fsprogs-devel
 # For ioemu PCI passthrough
 BuildRequires: pciutils-devel
 # modern compressed kernels

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]