[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-xen] Xen 3.4.1 dom0 crash on boot



On Tue, 15 Sep 2009, Charles Gruener wrote:

Thanks for the help on configuring my boot options. I apologize that I forgot to mention I'm using the latest kernel from M. Young, 2.6.31-1.2.65.xendom0.fc12.x86_64. Here's what I get now that I've done all of what you've said:

...

(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to Xen)
(XEN) Freed 128kB init memory.
(XEN) mm.c:1697:d0 Bad L1 flags 800000
(XEN) traps.c:437:d0 Unhandled invalid opcode fault/trap [#6] on VCPU 0 [ec=0000]
(XEN) domain_crash_sync called from entry.S
(XEN) Domain 0 (vcpu#0) crashed on cpu#0:
(XEN) ----[ Xen-3.4.1  x86_64  debug=n  Not tainted ]----
(XEN) CPU:    0
(XEN) RIP:    e033:[<ffffffff81a017f1>]
(XEN) RFLAGS: 0000000000000282   EM: 1   CONTEXT: pv guest
(XEN) rax: 00000000ffffffea   rbx: ffffffff8182b000   rcx: 00000000001b582b
(XEN) rdx: 0000000000000000   rsi: 80000001b582b061   rdi: ffffffff8182b000
(XEN) rbp: ffffffff8174ff98   rsp: ffffffff8174fef8   r8:  0000000000000000
(XEN) r9:  0000000000000000   r10: 0000000000000000   r11: 0000000000000000
(XEN) r12: ffffffff8174ffa8   r13: ffffffff8174ff40   r14: 0000000000000080
(XEN) r15: 0000000000000000   cr0: 000000008005003b   cr4: 00000000000026f0
(XEN) cr3: 00000001b7208000   cr2: 0000000000000000
(XEN) ds: 0000   es: 0000   fs: 0000   gs: 0000   ss: e02b   cs: e033
(XEN) Guest stack trace from rsp=ffffffff8174fef8:
(XEN)    00000000001b582b 0000000000000000 ffffffff81a017f1 000000010000e030
(XEN)    0000000000010082 ffffffff8174ff38 000000000000e02b ffffffff81a017ed
(XEN)    0000000000000000 0000000000000000 0000000000000000 0000000000000000
(XEN)    000000000000182b 0000008000000000 ffffffff8100cc87 0000000000000000
(XEN)    0000000000000000 0000000000000000 0000000000000000 0000000000000000
(XEN)    ffffffff8174ffc8 ffffffff81021271 ffff8182b000007f 000000000000ffff
(XEN)    0000000000000000 0000000000000000 ffffffff8174fff8 ffffffff81a01b49
(XEN)    0000000000000000 0000000000000000 0000000000000000 0000000000000000
(XEN)    0000000000000000
(XEN) Domain 0 crashed: rebooting machine in 5 seconds.

Looking through that information, I don't see anything that really helps me out. Am I missing something? Anything else I should try BIOS level that could shed some light on the nature of the issue or is my best bet to try booting a debug version of Xen?

You can dig the vmlinux file out of the debuginfo rpm http://koji.fedoraproject.org/koji/getfile?taskID=1668157&name=kernel-debuginfo-2.6.31-1.2.65.xendom0.fc12.x86_64.rpm feed it into gdb and see what x/i ffffffff81a017f1 tells you about what code it was trying to run when it crashed.

	Michael Young


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]