[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Re: qemud/.libs/libvirtd?



On Wed, Aug 20, 2008 at 08:01:42PM +0900, Jun Koi wrote:
> On Wed, Aug 20, 2008 at 4:30 PM, Jun Koi <junkoi2004 gmail com> wrote:
> > Hi,
> >
> > I added some new code to libvirt.c, and recompile. However, when "make
> > install". qemud/.libs/libvirtd is installed but not qemud/libvirtd.
> > Why? Looks like a bug?

No, this is correct behaviour.  qemud/libvirtd is not a binary - it is
a mere shell script which calls into qemud/.libs/libvirtd. This is all
part of the libtool build process.

> > The problem is that qemud/libvirtd has my new code, but not
> > qemud/.libs/libvirtd! So "make install" installs the old binary, which
> > I dont know where it is from. (Perhaps from the first compilation?)

You are mistaken - qemud/libvirtd is just a shell script wrapper.
The actual binaries are in the .libs directory.

> > I am not familiar with the autoconf Makefile, and cannot figure it out
> > why it is working this way.
> >
> 
> This is not getting funny anymore. I clean src/.libs/*, and
> qemud/.libs/*, and recompile and "make install" again. This step
> installed stuffs in .libs/ into system.

Run  'make distclean' and then start again from 'configure'

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]