[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH]Fix minor issues in logical storage backend



On Thu, Aug 28, 2008 at 06:15:27PM -0600, Jim Fehlig wrote:
> Hi All!
> 
> I came across some problems trying to create a new LVM-based storage
> pool using this config
> 
> <pool type="logical">
>   <name>test_vg</name>
>   <source>
>     <device path="/dev/sdb1"/>
>   </source>
>   <target>
>     <path>/dev/test_vg</path>
>   </target>
> </pool>
> 
> Volume group did not previously exist so I did
> virsh pool-define <above.xml>
> virsh pool-build test_vg
> 
> pool-build failed since the backend logical storage driver does not have
> VIR_STORAGE_BACKEND_POOL_SOURCE_DEVICE set in flags.  Without this flag
> set, the device element is never parsed in virStoragePoolDefParseDoc()
> (storage_conf.c), causing pvcreate to fail since no physical volume is
> specified.

Yep, mea-culpa. I went through so many re-designs & re-writes of the 
LVM modelling I guess I forgot to test pool creation in the final
code :-(

> After this problem was memory corruption cause by miscalculating the
> size of vgcreate command line :-).

Opps, not so much mis-calculating, as not calculating at all !.

ACK to this  patch

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]