[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Deploying latest libvirt in rhel / centos 5.2



On Tue, Dec 09, 2008 at 03:16:49PM +0100, Daniel Veillard wrote:
> On Tue, Dec 09, 2008 at 08:35:12AM -0500, Ben Guthro wrote:
> > You shouldn't have any issues.
> > 
> > There is a 'make rpm' target at the top level that I use to build
> > updated packages in RHEL.
> > Take a look at the top of the .spec.in file for build dependencies
> > 
> > Marco Sinhoreli wrote on 12/09/2008 08:00 AM:
> > > Hello all,
> > >
> > > I'm wanting to know if I will have some difficulty to package libvirt
> > > 0.5.x to rhel / centos 5.2. I'm needing of the latest libvirt release
> > > to tests with oVirt.
> > >
> > > Regards,
> 
>   Actually there are issues related to Xen specificities in RHEL5,
> but that's not a compile/packaging issue.

I have uploaded a set of patches which make libvirt 0.5.1 work with
RHEL-5's version of Xen. Basically we have to tweak a few version
assumptions to take account of fact that RHEL-5 Xen has a number of
feature backports like the new paravirt framebuffer and NUMA support

   http://berrange.fedorapeople.org/libvirt-rhel5-xen/

Of course running a newer libvirt on RHEL-5 is totally unsupported but 
hopefully these will be usful to those who absolutely need this newer
libvirt and don't mind about lack of support.

Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]