[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH 6/7] Enable NUMA support for RHEL-5



RHEL-5 supports NUMA since 5.2.  Relax the version number checks.
This breaks older versions, which will be fixed in the next commit.

Signed-off-by: Markus Armbruster <armbru redhat com>
---
 src/xen_internal.c |   10 ++++++++--
 1 files changed, 8 insertions(+), 2 deletions(-)

diff --git a/src/xen_internal.c b/src/xen_internal.c
index b3a531e..aada2e7 100644
--- a/src/xen_internal.c
+++ b/src/xen_internal.c
@@ -89,6 +89,12 @@ typedef privcmd_hypercall_t hypercall_t;
 #define __HYPERVISOR_domctl 36
 #endif
 
+#ifdef WITH_RHEL5_API
+#define SYS_IFACE_MIN_VERS_NUMA 3
+#else
+#define SYS_IFACE_MIN_VERS_NUMA 4
+#endif
+
 static int xen_ioctl_hypercall_cmd = 0;
 static int initialized = 0;
 static int in_init = 0;
@@ -2149,7 +2155,7 @@ xenHypervisorBuildCapabilities(virConnectPtr conn,
         goto no_memory;
 
 
-    if (sys_interface_version >= 4) {
+    if (sys_interface_version >= SYS_IFACE_MIN_VERS_NUMA) {
         if (xenDaemonNodeGetTopology(conn, caps) != 0) {
             virCapabilitiesFree(caps);
             return NULL;
@@ -2949,7 +2955,7 @@ xenHypervisorNodeGetCellsFreeMemory(virConnectPtr conn, unsigned long long *free
     /*
      * Support only sys_interface_version >=4
      */
-    if (sys_interface_version < 4) {
+    if (sys_interface_version < SYS_IFACE_MIN_VERS_NUMA) {
         virXenErrorFunc (conn, VIR_ERR_XEN_CALL, __FUNCTION__,
                         "unsupported in sys interface < 4", 0);
         return -1;
-- 
1.5.4.3


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]