[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Changing the QEMU svn VERSION string



Hi,

I'd like to update the VERSION string in QEMU's svn tree. Right now, it's 0.10.0 and since we have a 0.10.2 release, that's somewhat confusing.

I don't want to make it 0.11.0 either because that's not going to be reliable from a feature detection perspective. What I would like is to make it 0.11.0-devel or something similar to that.

Being the nice guy I am, I thought I would check that this didn't make libvirt go bonkers :-) This is the relevant detection code in libvirt:


if (sscanf(help, "QEMU PC emulator version %u.%u.%u (kvm-%u)",
          &major, &minor, &micro, &kvm_version) != 4)
    kvm_version = 0;

if (!kvm_version && sscanf(help, "QEMU PC emulator version u.%u.%u",
    &major, &minor, &micro) != 3)
    goto cleanup2;

If I change SVN to 0.11.0-devel, that's going to break the KVM string although the QEMU string will continue to work. Avi could potentially carry a patch to keep it 0.10.x and since kvm-%u will be used to identify features, that should keep things working.


Anyone have any objections/suggestions?

Regards,

Anthony Liguori


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]