[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] PATCH: 17/25: Concurrent client dispatch in libvirtd



Daniel P. Berrange wrote:

+qemudClientMessageQueuePop(struct qemud_client_message **queue)

The daemon needs a FIFO queue for fairness, so removing from head
is correct. To avoid confusion with Perl's push/pop/shift/unshift
semantics I should rename this Pop method to Shift instead.

Just my $.02, how about qemudClientMessageEnqueue and qemudClientMessageDequeue? I associate push and pop with stacks, not queues.

Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]