[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Patch] Fix detach tap device on Xen3.3.1



Hi Daniel-san,

Thank you for your infomation.

I would like to know your plan to commit the following patch.
If there is not problem, please commit it.
https://bugzilla.redhat.com/show_bug.cgi?id=475791

Thanks,
Tomohiro Takahashi.

Daniel P. Berrange wrote:
On Mon, Mar 09, 2009 at 01:30:50PM +0900, Takahashi Tomohiro wrote:
Hi,

I made the patch that corrected the following problem.

It is that when I executed the "virsh detach-disk" command on Xen3.3.1,
Libvirt could not detach tap device and output the following error
message.

# virsh detach-disk Fedora xvdd
libvir: Xen Daemon error : POST operation failed: xend_post: error
from xen daemon: (xend.err 'Device 51760 not connected')

The cause of this problem is incompatible of Xen3.3.0 and Xen3.3.1.
I think Xen specific was changed by the following patch.
http://xenbits.xensource.com/xen-3.3-testing.hg?rev/e0e17216ba70

If you have any comments, please suggest me.

Signed-off-by: Tomohiro Takahashi <takatom jp fujitsu com>

Thanks for reminding me about this problem - we've actally been tracking
this in BZ too.

  https://bugzilla.redhat.com/show_bug.cgi?id=475791

There's a patch in that bug which does basically the same thing as
yours, but with STREQ & an additional check to avoid NULL dereference


Daniel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]