[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Error in virt-install



On Tue, Mar 10, 2009 at 11:03:12AM +0000, Nuno Fernandes wrote:
> Hi,
> 
> After applying your patch i didn't get any error like memory corruption.
> Nevertheless i was able to access graphics using vnc. Even specifying vnc it 
> tries to open display (maybe something requires it - virt-viewer).
> 
> [root localhost ~]# virt-install  -n test -r 512 --vnc --
> file=/dev/VolGroup00/test-os --location=ftp://mirrors/centos/5/os/i386 -x 
> 'text' --vncport=5900                                                                                                  
> 
> 
> Starting install...
> Retrieving file .treeinfo 100% |=========================|  413 B    00:00     
> Retrieving file vmlinuz.. 100% |=========================| 2.1 MB    00:00     
> Retrieving file initrd.im 100% |=========================| 5.4 MB    00:00     
> Creating domain...                                                 0 B 00:01   
> 
> (virt-viewer:4021): Gtk-WARNING **: cannot open display:  
> Domain installation still in progress.  You can reconnect to 
> the console to complete the installation process.           

Yes, at this point it has tried to start 'virt-viewer' to show you the
VNC console to complete installation. The fact that it couldn't start
it was not a serious problem - you could easily start it yourself as 
you discovered. If you wanted to supress the error, you could pass the
--noautoconsole flag to virt-install, which stops it trying to launch
virt-viewer at all.

> I access the console using vnc but as you said, after the instalation 
> completes it didn't restart. It disappeared from "virsh list" but i'm able to 
> start it again using:
> 
> [root localhost ~]# virsh start test
> Domain test started
> [root localhost ~]# virsh list
>  Id Name                 State
> ----------------------------------
>   0 Domain-0             running
>   3 test                 idle
> 
> If there's anything i can do to help please let me know.

This is actually the expected behaviour. Since virt-viewer could not be
started directly, virt-install finished leaving you to manually restart
the guest once installation was complete. If virt-install had been able
to launch virt-viewer, it would have automatically restarted the guest
once install was complete. 


Regards,
Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]