[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Build libvirt 0.9.3 failed



于 2011年07月20日 14:20, zhang xintao 写道:
config.log
38094 configure:54859:checking for LIBNL
38995 configure:54924:result: no
38096 configure:54924:error: libnl-devel>= 1.1 is required for macvtap support

I try to build libvirt 0.9.3 -without macvtap support but failed

  same error message.


Can you try to see if "pkgconfig" works well for you?

# pkg-config --cflags --libs libnl-1

I'm doubting about the metadata file for your libnl-dev package
is not named libnl-1.pc, but something else.

Or to check if the libnl version is >= 1.1

# pkg-config --atleast-version=1.1 libnl-1
# echo $?

But anyway it's weird that you can still see the error message when
compiling with with_macvtap=no. Doesn't make sense.

Osier
  can you help me ?

On Wed, Jul 20, 2011 at 2:02 PM, zhang xintao<zhang kvm gmail com>  wrote:
This is th config.log

I try to build libvirt 0.9.3 -without macvtap support but failed

same error message.

can you help me ?

On Wed, Jul 20, 2011 at 12:52 PM, Eric Blake<eblake redhat com>  wrote:
On 07/19/2011 10:42 PM, zhang xintao wrote:
I try to build libvirt 0.9.3 but failed
==========================
Host OS:Ubuntu server 11.04
==========================
configure:error libnl-devel>= 1.1 is required for macvtap support

libnl-dev 1.1-6 is already installed

who can help me?
What does config.log say in the areas where it was checking for libnl
support?  Meanwhile, are you okay building without macvtap support?

--
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

--
libvir-list mailing list
libvir-list redhat com
https://www.redhat.com/mailman/listinfo/libvir-list


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]