[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt cannot be built with -Werror on RHEL6RC(x86_64)



On 05/12/2011 12:40 AM, Wen Congyang wrote:
> My steps to build libvirt:
> 1. # export CFLAGS=-Werror

The general advice from the gnulib list is that using -Werror during the
duration of ./configure is unsupported.  There are a number of
gnulib-supplied configure tests that get the wrong answer if -Werror is
on too early, with no plans to fix those upstream in gnulib, so
downstream libvirt cannot control all the problems caused by adding
-Werror to CFLAGS before configure.  Rather, it's better to rely on the
./configure --enable-compile-warnings=error, which libvirt uses to probe
if -Werror works, then ensure that -Werror is used during the Makefile
when building sane code, but omitted during configure tests where the
code is intentionally hairy.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]