[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Linux-cluster] Problems to start ony one cluster service



Hi all

I have a very strange problem. I have configured three nodes under RHCS on rhel5.1 servers. All works ok, except for one service that never starts when rgmanager start-up. My cluster conf is:

<?xml version="1.0"?>
<cluster alias="RhelXenCluster" config_version="17" name="RhelXenCluster">
        <fence_daemon post_fail_delay="0" post_join_delay="3"/>
        <clusternodes>
                <clusternode name="rhelclu01.hpulabs.org" nodeid="1" votes="1">
                        <fence>
                                <method name="1">
<device name="gnbd-fence" nodename="rhelclu01.hpulabs.org"/>
                                </method>
                        </fence>
                        <multicast addr="239.192.75.55" interface="eth0"/>
                </clusternode>
                <clusternode name="rhelclu02.hpulabs.org" nodeid="2" votes="1">
                        <fence>
                                <method name="1">
<device name="gnbd-fence" nodename="rhelclu02.hpulabs.org"/>
                                </method>
                        </fence>
                        <multicast addr="239.192.75.55" interface="eth0"/>
                </clusternode>
                <clusternode name="rhelclu03.hpulabs.org" nodeid="3" votes="1">
                        <fence>
                                <method name="1">
<device name="gnbd-fence" nodename="rhelclu03.hpulabs.org"/>
                                </method>
                        </fence>
                        <multicast addr="239.192.75.55" interface="xenbr0"/>
                </clusternode>
        </clusternodes>
        <cman expected_votes="1" two_node="0">
                <multicast addr="239.192.75.55"/>
        </cman>
        <fencedevices>
<fencedevice agent="fence_gnbd" name="gnbd-fence" servers="rhelclu03.hpulabs.org"/>
        </fencedevices>
        <rm log_facility="local4" log_level="7">
                <failoverdomains>
<failoverdomain name="PriCluster" ordered="1" restricted="1"> <failoverdomainnode name="rhelclu01.hpulabs.org" priority="1"/> <failoverdomainnode name="rhelclu02.hpulabs.org" priority="2"/>
                        </failoverdomain>
<failoverdomain name="SecCluster" ordered="1" restricted="1"> <failoverdomainnode name="rhelclu02.hpulabs.org" priority="1"/> <failoverdomainnode name="rhelclu01.hpulabs.org" priority="2"/>
                        </failoverdomain>
                </failoverdomains>
                <resources>
			<ip address="172.25.50.10" monitor_link="1"/>
                        <ip address="172.25.50.11" monitor_link="1"/>
                        <ip address="172.25.50.12" monitor_link="1"/>
                        <ip address="172.25.50.13" monitor_link="1"/>
                        <ip address="172.25.50.14" monitor_link="1"/>
                        <ip address="172.25.50.15" monitor_link="1"/>
                        <ip address="172.25.50.16" monitor_link="1"/>
                        <ip address="172.25.50.17" monitor_link="1"/>
                        <ip address="172.25.50.18" monitor_link="1"/>
                        <ip address="172.25.50.19" monitor_link="1"/>
                        <ip address="172.25.50.20" monitor_link="1"/>
                </resources>
<service autostart="1" domain="PriCluster" name="dns-svc" recovery="relocate">
                        <ip ref="172.25.50.10">
<script file="/data/cfgcluster/etc/init.d/named" name="named"/>
                        </ip>
                </service>
<service autostart="1" domain="SecCluster" name="mail-svc" recovery="relocate">
                        <ip ref="172.25.50.11">
<script file="/data/cfgcluster/etc/init.d/postfix-cluster" name="postfix"/>
                        </ip>
                </service>
<service autostart="1" domain="SecCluster" name="rsync-svc" recovery="relocate">
                        <ip ref="172.25.50.13">
<script file="/data/cfgcluster/etc/init.d/rsyncd" name="rsyncd"/>
                        </ip>
                </service>
<service autostart="1" domain="PriCluster" name="wwwsoft-svc" recovery="relocate">
                        <ip ref="172.25.50.14">
<script file="/data/cfgcluster/etc/init.d/httpd-mirror" name="httpd-mirror"/>
                        </ip>
                </service>
<service autostart="1" domain="SecCluster" name="proxy-svc" recovery="relocate">
                        <ip ref="172.25.50.15">
<script file="/data/cfgcluster/etc/init.d/squid" name="squid"/>
                        </ip>
                </service>
        </rm>
</cluster>

The service that returns me errors and never starts when rgmanager start-up is postfix-cluster. On maillog file I find this error:

Nov 26 11:27:31 rhelclu01 postfix[27959]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:27:43 rhelclu01 postfix[28313]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:27:44 rhelclu01 postfix[28334]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:27:55 rhelclu01 postfix[28589]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:30:04 rhelclu01 postfix[30350]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:30:13 rhelclu01 postfix[30622]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:30:14 rhelclu01 postfix[30643]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:30:26 rhelclu01 postfix[30834]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:31:41 rhelclu01 postfix[31888]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:31:42 rhelclu01 postfix[31909]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied Nov 26 11:31:53 rhelclu01 postfix[32249]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:32:12 rhelclu01 postfix[32351]: fatal: parameter inet_interfaces: no local interface found for 172.25.50.11 Nov 26 11:32:31 rhelclu01 postfix[32668]: fatal: /data/cfgcluster/etc/postfix-cluster/postfix-script: Permission denied

but thath's not true. If I start this service manually all works ok. Postfix configuration it is ok, What can be the problem??? I don't know why rgmanager dosen't config 172.25.50.11 address before execute postfix-cluster service ....
--
CL Martinez
carlopmart {at} gmail {d0t} com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]