[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] 0.9 tools compatible with 0.8 kernel? (and vice versa)



Paul writes:
> i want to try out test13-pre4, which i see has LVM v0.9 rolled in.
> 
> if i need to revert to a previous kernel with 0.8, would that cause a
> problem?

Yes,

> and if it doesn't, will the 0.9 tools work with 0.8 kernel side?

No.

> (they should, or upgrade path is pretty risky).

Yes, that's why we have been discussing all of the "LVM user tools wrappers"
issues here over the last week.  With the current setup, you can't even
_install_ multiple versions of the LVM tools at the same time, let alone
have a single version handle multiple protocols.

Try out Marcelo's latest LVM user tools install, which is really required
before trying to update your system, as it allows multiple versions of
user tools to be installed and work well.  Also keep a boot floppy with the
LVM 0.8 and LVM 0.9 tools available in case of trouble, if you don't have
an emergency non-LVM boot partition.

rpm http://distro.conectiva.com.br/experimental/

Cheers, Andreas
-- 
Andreas Dilger  \ "If a man ate a pound of pasta and a pound of antipasto,
                 \  would they cancel out, leaving him still hungry?"
http://www-mddsp.enel.ucalgary.ca/People/adilger/               -- Dogbert


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]