[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Re: more LVM 0.8 patches



On Mon, Oct 23, 2000 at 12:00:01PM -0600, Andreas Dilger wrote:
> Luca Berra writes:
> > hello here are more lvm patches.
> > they apply over patches in lvm-0.8final-3.3.src.rpm
> > 1st chunk is needed to compile on my system
> 
> Actually, this is a bit of a problem.  In my 2.2 kernel patch, I include an
> lvm.h that can be used for both user and kernel compiles, so that you are
> sure you have the same IOP version, struct sizes, etc.  However, this lvm.h
> doesn't exist on 2.4.

IMHO this is the wrong thing. Userlevel tools should not include kernel headers.
IOP version mismatches are detected at run time.
In my RPMs I keep including the userlevel header and it works fine for Linux 2.2
and 2.4. The RPMs do also include most fixes by Andreas and from this list
(Luca's have just been added). If anyone is interested, they can be found on
	
  ftp.openlinux.org:/pub/people/hch/lvm/lvm-tools-0.8final-5.src.rpm
  ftp.openlinux.org:/pub/people/hch/lvm/lvm-tools-0.8final-5.i386.rpm (Glibc 2.1.94)


	Christoph

-- 
Always remember that you are unique.  Just like everyone else.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]