[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] segfault running vgscan



On Wed, Aug 22, 2001 at 06:10:53PM -0700, Brad Langhorst wrote:
> I've carefully followed the instructions in INSTALL
> and the build seems to go fine.
> This is the first install of lvm so there are no vgs
> or pvs or anything yet.
> 
> I patched the kernel  (2.4.9)
> installed the kernel
> make in LVM
> make install
> reboot
> run vgscan -d  
> 
> this just generates a segfault and dumps core

Are you linking the tools statically or dynamically?  I have seen a
seg-fault with the tools that call at_exit() and static linking with glibc -
apparently the bug is in glibc, not LVM, and is fixed in newer versions.  I
have yet to verify this.
 
-- 
AJ Lewis
Sistina Software Inc.                  Voice:  612-638-0500
1313 5th St SE, Suite 111              Fax:    612-638-0500
Minneapolis, MN 55414                  E-Mail: lewis sistina com
http://www.sistina.com

Current GPG fingerprint = 3B5F 6011 5216 76A5 2F6B  52A0 941E 1261 0029 2648
Get my key at: http://www.sistina.com/~lewis/gpgkey
 (Unfortunately, the PKS-type keyservers do not work with multiple sub-keys)

-----Begin Obligatory Humorous Quote----------------------------------------
All wiyht. Rho sritched mg kegtops awound?
-----End Obligatory Humorous Quote------------------------------------------

Attachment: pgp00027.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]