[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] pvscan - - invalid i/o protocol version



Hi,

I'm new to LVM, and desperate to get it working on a 3 disk linux box.
I'm running Kernel version 2.4.6, and installed the binary 'RedHat' version 8.1 of LVM.
I have compiled the kernel with LVM as a module, and everything seems to work fine at bootup (/proc/lvm is there).
The module is loaded at bootup, and i put the vgscan and vgchange scripts in rc.sysinit.


I have changed the partition type of hdb, and hdc to 0x8e. But when i try to run pvcreate /dev/hdb1 i get:

pvcreate - - ERROR: "/etc/lvmtab" doesn't exist; please run vgscan.

And when i run vgscan:

vgscan - - invalid i/o protocol version

What did i do wrong? Did i install the wrong version of LVM?
Any help will be greatly appreciated.

Pascal.
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]