[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Mixing different versions of user-level tools and kernel LVM?



 Are there any guidelines on how mixable various versions of user level
tools and the kernel LVM code are?

 I prefer to test-boot new kernels before comitting to them, which is a
bit difficult if the user-level tools must be strictly synchronized to
the kernel versions.

 So I am wondering how widely it is safe to wander: for example, can
0.9.1_beta8 user level tools be used safely to assemble and start up
volume groups with kernel LVM 1.0 or 1.0.1rc2 code? Can the latest
user-level vgscan/vgchange be used safely with the 0.9.1_beta8 kernel
code?

 Is it the case that on-disk format changes are the important
breakpoints (eg beta7 to beta8), or are there others? Is this
documented anywhere?

	- cks



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]