[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] LVM 1.0.4 pvmove is broken



	I posted a day or two ago, and as near as I can tell pvmove in LVM
1.0.4 with kernel 2.4.18 is broken. If I apply the 1.0.4 patch generated by
PATCHES/Makefile to a stock 2.4.18 kernel, pvmove will crash after moving
one PE, every time, regardless of the arrangement of physical volumes,
filesystems, etc. Notice that this failure occurs even without a filesystem
present in the logical volume, that is I can make a volume group with two
disks, create a small LV and pvmove will crash trying to move the PEs. If I
follow the exact same installation procedure for LVM 1.0.3, everything works
fine. If I use the 1.0.4 toolset with an unpatched stock 2.4.18 kernel,
everything works fine. The problem with pvmove is definitely precipitated by
installing the auto-generated patch from 1.0.4. 

	Is this working for anyone else? I didn't want to attach the
auto-generated patch since it is 70k, but I can provide it if it would help.

Thanks,

-poul

System Specs:
RedHat 7.2 w/ 2.4.18 kernel
Dual P-II 400 




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]