[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Poor performance with LVM 1.0.7



On Wed, Aug 27, 2003 at 02:05:55PM +0200, Henric Andersson wrote:
> > check the raw performance of one drive involved
> > with hdparm -tT ...
> 
> Did that, it reported between 27-45MB/s on all drives (ranging from the system harddrive to the LVM
> harddrives)

I asked this, because I reported several times that
lvm does have some I/O bottleneck/issue ...

I had a similar problem with RAID5 where I could
get 16Mb/s from each disk and about 30Mb/s from
the RAID5 (4 disks) but only 18Mb/s from the lvm
ontop of that raid ...

> > > After scouring the net for suggestions on how to improve the speed, I came
> > > up empty, and thus, I'm writing this email :)
> > >
> > > Some more facts (more available if needed ;)) about the server:
> > >
> > > All drives are tuned with 32bit transfers and DMA enabled. I'm running
> > > kernel 2.4.22pre2 (gentoo).
> >
> > just for the fun of doing it, compile vanilla
> > 2.4.22 and give it a try ... you could also add
> 
> Oki, will try it as soon as I get home.
> 
> > the following lvm patch ...
> > http://www.13thfloor.at/VServer/patches-2.4.22-p10c17/07_lvm-1.0.7-2.4.21pre5.patch.bz2
> 
> Hmm? What does this patch do?

get lvm up to version 1.0.7 ...

> > was the performance you had on your old box higher?
> > or did you just expect an increase in speed, which didn't
> > happen?
> 
> Performance on my old box was lower, so I expected it to 
> increase with my new system. And it did, as
> long as I don't serve any files from the volumeset, 
> everything runs just fine (9.5MB/s) but whenever I
> try to access files on the LV, I get 4-5MB/s ...
> 
> Even tried doing:
> 
> time cat "somefile on the LV set" > /dev/null
> 
> Which performed equally bad (ie, about 4-5MB/s). 
> Doing the same on the /dev/hda1 drive gives ALOT
> better performance (more in the line of what hdparm -Tt reports)

this was, on one of my systems, the reason why
I removed the lvm and used the plain disk ...

Heinz suggested to use the new LVM2 anyway, and maybe
this is an option for you, so you could try this too 
(if you need patches for LVM2, hopefully they will be 
available for 2.4.22 this evening ...)

HTH,
Herbert

> /Henric



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]