[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] snapshots+highmem+'md raid5'



On Fri, Jun 13, 2003 at 05:20:27PM -0700, Petro wrote:
> On Fri, Jun 13, 2003 at 01:55:01AM +0200, Herbert Poetzl wrote:
> > On Thu, Jun 12, 2003 at 03:28:59PM +0200, Koch, Steffen wrote:
> > > If someone has a solution for this please help.
> > hmm, do you have himem enabled (in kernel config)?
> > if yes, try to disable it ...
> 
>     Does this apply to RAID 0 as well? 
> 
>     I've got several boxes running with:
> 
>     CONFIG_HIGHMEM4G=y
>     # CONFIG_HIGHMEM64G is not set
>     CONFIG_HIGHMEM=y
> 
>     And 2-4 GiB of ram under 2.4.18, with LVM 1.03. 
> 
>     I'm trying to get LVM 1.07 to compile with 2.4.21 with :
>     
>     CONFIG_HIGHMEM4G=y
>     # CONFIG_HIGHMEM64G is not set
>     CONFIG_HIGHMEM=y
>     CONFIG_HIGHIO=y
> 
> 
>     Why is this bad? 

didn't say that this would be bad, only that
it live-locked my system at high load ...
the tenor on the list was: "highmem is bad"
so I turned it off, and, voila the system was
stable again ...

another, yet unexplained issue, is that on
another system, 4 SCSI discs, form a RAID 5
array (software) which gives about 35MB
throughput, but lvm 1.0.7 ontop of that md
only has about 18MB throughput ...

YMMV,
Herbert

> -- 
> "On two occasions, I have been asked [by members of Parliament], 'Pray, 
> Mr. Babbage, if you put into the machine wrong figures, will the right 
> answers come out?' I am not able to rightly apprehend the kind of confusion 
> of ideas that could provoke such a question." -- Charles Babbage 
> 
> _______________________________________________
> linux-lvm mailing list
> linux-lvm sistina com
> http://lists.sistina.com/mailman/listinfo/linux-lvm
> read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]