[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] once again about 2.6 kernel



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wednesday 15 October 2003 14:08, Valentine Kouznetsov wrote:
> Hi,
> I had a look at lvm mailing list about kernel 2.6
> questions. So far I understood that in order to run
> 2.6 kernel with LVM2 on a system which previously run
> 2.4 kernel with LVM1 you need
> 1) patch 2.4 kernel with device-mapper patch
> 2) use new LVM2 tools (LVM2.2.00.07) which need to be
> installed separetly on the system to allow
> simulteneously use LVM1 and LVM2
>
> Is it correct?

Not from what little I know.
LVM2 can read LVM1 metadata, and convert it to LVM2. I've done this myself 
too, so I know it works! :)
Take a look at vgconvert.
The only problem you may have if you convert the metadata is not being able to 
go back to 2.4 without the patching you mention.

- -- 
Mike Williams
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/jY1LInuLMrk7bIwRAr0vAJwNRAfnU2VH2KanHSgQ+tCn4ZAKPACeLZRN
oLmkQ4QUsMsTmkwv7fhMoWI=
=YNCy
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]