[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Can't install LVM 1.0.7 on Redhat Advanced Server 2.1 Please help.



I have been struggling over the past 5 hours to get
LVM installed on my RH AS 2.1 server but it's just no
go. I have the 2.4.9-e.25enterprise kernel installed,
and when I am done un-tarring the files. 

I run the ./configure --with-kernel_dir=/boot    
command, as I could not find a /usr/src/linux
directory.. (There are no directories under /usr/src)

Apparently, half-way during there was an error saying 

=====
linuxver - /boot/Makefile does not exist
*** Unable to determine version of linux to build
patches for ***
*** Consider using the --with-kernel_dir flag         
       ***
=========
Does anyone know where the kernel_dir for RH AS is? I
would think it's in the /boot folder.

 grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making
changes to this file
# NOTICE:  You have a /boot partition.  This means
that
#          all kernel and initrd paths are relative to
/boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro
root=/dev/ida/c0d5p3
#          initrd /initrd-version.img
#boot=/dev/ida/c0d0
default=1
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.9-e.25enterprise)
        root (hd0,0)
        kernel /vmlinuz-2.4.9-e.25enterprise ro
root=/dev/ida/c0d5p3
        initrd /initrd-2.4.9-e.25enterprise.img


]# ll /boot
total 18930
-rw-r--r--    1 root     root         5824 Jun 25 
2001 boot.b
-rw-r--r--    1 root     root          612 Jun 25 
2001 chain.b
drwxr-xr-x    2 root     root         1024 Sep 10
19:42 grub
-rw-r--r--    1 root     root       249577 Sep 10
16:47 initrd-2.4.9-e.25enterprise.img
-rw-r--r--    1 root     root       246403 Sep 10 
2003 initrd-2.4.9-e.3enterprise.img
-rw-r--r--    1 root     root       241848 Sep 10 
2003 initrd-2.4.9-e.3.img
-rw-r--r--    1 root     root       246381 Sep 10 
2003 initrd-2.4.9-e.3smp.img
lrwxrwxrwx    1 root     root           14 Sep 10
17:55 kernel.h -> kernel.h-2.4.9
-rw-r--r--    1 root     root          428 Sep 10
18:39 kernel.h-2.4.9
drwx------    2 root     root        12288 Sep 10 
2003 lost+found
-rw-r--r--    1 root     root        23108 Jun 25 
2001 message
lrwxrwxrwx    1 root     root           21 Sep 10 
2003 module-info -> module-info-2.4.9-e.3
-rw-r--r--    1 root     root        13599 Jun  7
06:07 module-info-2.4.9-e.25enterprise
-rw-r--r--    1 root     root        13599 May  4 
2002 module-info-2.4.9-e.3
-rw-r--r--    1 root     root        13599 May  4 
2002 module-info-2.4.9-e.3enterprise
-rw-r--r--    1 root     root        13599 May  4 
2002 module-info-2.4.9-e.3smp
-rw-r--r--    1 root     root          640 Jun 25 
2001 os2_d.b
lrwxrwxrwx    1 root     root           31 Sep 10
17:19 System.map -> System.map-2.4.9-e.25enterprise
-rw-r--r--    1 root     root       469339 Jun  7
06:07 System.map-2.4.9-e.25enterprise
-rw-r--r--    1 root     root       444721 May  4 
2002 System.map-2.4.9-e.3
-rw-r--r--    1 root     root       466214 May  4 
2002 System.map-2.4.9-e.3enterprise
-rw-r--r--    1 root     root       466091 May  4 
2002 System.map-2.4.9-e.3smp
-rwxr-xr-x    1 root     root      3138379 Jun  7
06:07 vmlinux-2.4.9-e.25enterprise
-rwxr-xr-x    1 root     root      2767809 May  4 
2002 vmlinux-2.4.9-e.3
-rwxr-xr-x    1 root     root      3105369 May  4 
2002 vmlinux-2.4.9-e.3enterprise
-rwxr-xr-x    1 root     root      3097034 May  4 
2002 vmlinux-2.4.9-e.3smp
lrwxrwxrwx    1 root     root           17 Sep 10 
2003 vmlinuz -> vmlinuz-2.4.9-e.3
-rw-r--r--    1 root     root      1088359 Jun  7
06:07 vmlinuz-2.4.9-e.25enterprise
-rw-r--r--    1 root     root       997736 May  4 
2002 vmlinuz-2.4.9-e.3
-rw-r--r--    1 root     root      1076755 May  4 
2002 vmlinuz-2.4.9-e.3enterprise
-rw-r--r--    1 root     root      1073371 May  4 
2002 vmlinuz-2.4.9-e.3smp
[root test grub]# 

If the kernel is located at the boot, how come I can't
seem to configure it right? I need to get the patch
done for my kernel before it works, right now none of
the LVM commands work.

I have read the INSTALL and README file but still have
no clues.

Appreciate any help rendered.

Thanks in Advance.

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]