[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] new process dead after create multiple snapshot volumes



/ 2005-09-12 10:34:15 +0800
\ Bear Wolf:
> Dear all 
> 
> I test snapshot function on my system.
> when I create the first snapshot, everything works fine.
> then I create more snapshot, everything works fine too.
> but when I access the source volume and do sync
> the sync command will be dead.
> 
> and I test with a script file
> 
> I=0
> for I in 1 2 3 4 5 6 7 8 9
> do
> cp -af /etc /mnt/volume1
> lvcreate -s -L 64 -n snaplv${I} /dev/VG01/volume1
> sleep 1
> done
> 
> after create the 4th sn apshot volume, the system process hang without
> any error message.

lvcreate calls into device mapper.
it suspends the affected targets, changes "tables", creates new targets,
and resumes the targets again.

if it fails to create the new targets, or fails to adjust the "tables",

then it unfortunately aborts, leaving the existing targets in suspended
state. I think that is a bug.

to get the system working (sort of) again, you could try to
for d in /dev/mapper/* ; do
	[[ $d == control ]] && continue
	dmsetup resume $d &
	               # ^^^ important! background it!
done

background it, because if you "resume" some target that depends on some
other target in suspended state, it will hang and wait for that other
target to be resumed... doh.

worked for me... (well, to get the system back, at least).

see also dmsetup ls, dmsetup info, dmsetp table etc.

cheers,

-- 
: Lars Ellenberg                                  Tel +43-1-8178292-0  :
: LINBIT Information Technologies GmbH            Fax +43-1-8178292-82 :
: Schoenbrunner Str. 244, A-1120 Vienna/Europe   http://www.linbit.com :


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]