[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [linux-lvm] Can not use vgimportclone multiple times for the attached disk



Hi,

Sorry for my ignorance. 
The culprit was "Vgremove -f NEWVG" in my step. :)

Thnx&Rgds,
KauShik SarKar 
SMAI - WinQA (SMVI)
NetApp
+91-80-4184-3392 Direct
kaushik sarkar netapp com



-----Original Message-----
From: Sarkar, Kaushik 
Sent: Thursday, April 01, 2010 4:10 PM
To: 'linux-lvm redhat com'
Subject: Can not use vgimportclone multiple times for the attached disk

Hi,

I successfully mounted the associated logical volume from the backup of
the same machine.
Before SCSI scan I have only /dev/sda2
After SCSI bus scan (rescan-scsi-bus.sh) I can see the new disk attached
to my RHEL machine.

# vgimportclone -n NEWVG /dev/sdc2

It successfully rename the VG.
#vgchange -ay NEWVG

I am able to mount the logical volumes associated with this VG to verify
the backup.

After verifying I un-mounted logical volume and remove the volume group.
Vgremove -f NEWVG 

But the new disk /dev/sdc2 still attached
I tried to do vgimportclone again it fails
# vgimportclone -n NEWVG /dev/sdc2
Fatal: /dev/sdc2 is not a PV., error: 5

I tried to remove the physical volume labeling then tried from the fresh
but still no luck.
#Pvremove -f /dev/sdc2
# rescan-scsi-bus.sh
# vgimportclone -n NEWVG /dev/sdc2
Fatal: /dev/sdc2 is not a PV., error: 5

What went wrong? What is the correct step to achieve it.

Thnx&Rgds,
KauShik SarKar


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]