[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[linux-lvm] Problem executing lvm related commands



Hi All,

 Need the suggession for the folling issues :

   Operating  System : rhel 5.5 ,  86_64 

  In our environment,  16 nodes are in cluster and shared storage is being used.
  Multipath is used, and there was no aliases.  The  admins  created the disk,
  with the /dev/dm....

  Now they changed the  multipath  config  file and incorporated  the aliases.

  The alias names are as follows:

             HOST-1TB-CLVM-VG04-DISK1
             HOST-1TB-CLVM-VG02-DISK1

  and so on. 

  They  use  the filter  in lvm.conf  as   filter = [ "r/scsi.*/","r/pci.*/","r/sd.*/","a/.*/" ]

  They did not enable  the  "preferred_names"   option in lvm.conf


  Now the problem is, lvm related  any commands are getting hung. 

  While debugging the issue I activated the "preferred_names"  option   in lvm.conf

  and found the errors  as follows:

     [root server ~]# lvs
  File descriptor 4 (/dev/pts/0) leaked on lvs invocation. Parent PID 20817: bash
  WARNING: Ignoring duplicate config node: preferred_names (seeking preferred_names)

I mentioned literally all the vgnames  under "preferred_names"  in lvm.conf but  still the 
errors are same. 

If anybody gives some suggesstion , how to rectify the issue  that  will be really helpful.


Thanks  in advance




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]