[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Ovirt-devel] ovirt see only 1 node. how to add other servers ?



В Птн, 12/12/2008 в 12:00 -0500, Perry Myers пишет:
> �� wrote:
> > В Птн, 12/12/2008 в 10:31 -0500, Perry Myers пишет:
> >> �� wrote:
> >>> Hello
> >>> i send identify information from second node starting
> >>> "ovirt-identify-node -s 192.168.50.2 -p 12120 -d -v"
> >>> but in listing "Hosts" hypervisor field  empty
> >>> i think ovirt-appliance can't connect to libvirtd
> >> Why are you running ovirt-identify-node manually?  That should run only as 
> >> part of the Node bootup sequence automatically.
> > 
> > Automaticaly this query "dig +short -t srv _$1._$2.$(dnsdomainname)"
> > from /etc/init.d/ovirt-functions haven't answer (i didn't configure dns
> > for local zones).
> 
> DNS on the oVirt Appliance is provided by dnsmasq which provides the DNS 
> SRV records that oVirt needs automatically.  The Appliance won't work with 
> external DNS without major changes to it.
> 
>  From the .254 Node and the Appliance what is the output of:
> 
> dig +short -t srv _ovirt._tcp.priv.ovirt.org

hello
i set in /etc/resolv.conf "nameserver 192.168.50.2" in all nodes 
after that "dig +short -t srv _ovirt._tcp.priv.ovirt.org" output is "0 0
80 management.priv.ovirt.org." 
> >> Are you running that on the 192.168.50.254 host or is this a different 
> >> physical machine?
> > physical machine is 192.168.50.254 and 192.168.50.1
> 
> Ok
> 
> > ovirt-appliance virtual machine is 192.168.50.2 on 192.168.50.1
> 
> Ok
> 
> >> In the logs you sent, the only hosts that I can see that have tried to 
> >> register with the Server are 192.168.50.254 and 192.168.50.1.  If there 
> >> are other nodes that have tried to register, the host-browser daemon on 
> >> the Appliance did not see them.  Can you give me the logs from these other 
> >> nodes?
> >>
> >> I also saw errors like this in your host-status log:
> >>
> >>> Connecting to host 192.168.50.254
> >>> libvir: Remote error : Failed to start SASL negotiation: -4 (SASL(-4): no mechanism available: No worthy mechs found)
> >> This could be a time synchronization issue.  Please run
> >> date --utc
> >> on both the host running the Appliance, the appliance and all nodes and 
> >> let me know what the results are
> > on all nodes time is Fri Dec 12 15:43:58 UTC 2008
> > 			Fri Dec 12 15:43:49 UTC 2008
> > 			Fri Dec 12 15:43:40 UTC 2008
> 
> Ok, so not a time sync issue then
> 
> >> Also, from your appliance in an ssh session try:
> >>
> >> klist
> >> ping -c 1 192.168.50.254
> >> virsh -c qemu+tcp://192.168.50.254/system list
> >>
> >> And give me the output for those commands.
> > 
> > [root management ~]# klist 
> > Ticket cache: FILE:/tmp/krb5cc_0
> > Default principal: admin PRIV OVIRT ORG
> > 
> > Valid starting     Expires            Service principal
> > 12/12/08 14:13:19  12/13/08 14:13:19
> > krbtgt/PRIV OVIRT ORG PRIV OVIRT ORG
> > 12/12/08 14:13:20  12/13/08 14:13:19
> > ldap/management priv ovirt org PRIV OVIRT ORG
> > 12/12/08 14:13:20  12/13/08 14:13:19
> > HTTP/management priv ovirt org PRIV OVIRT ORG
> > 
> > 
> > Kerberos 4 ticket cache: /tmp/tkt0
> > klist: You have no tickets cached
> > [root management ~]# virsh -c qemu+tcp://192.168.50.254/system list
> > libvir: Remote error : Failed to start SASL negotiation: -4 (SASL(-4):
> > no mechanism available: No worthy mechs found)
> > error: failed to connect to the hypervisor
> > [root management ~]# ping -c 1 192.168.50.254
> > PING 192.168.50.254 (192.168.50.254) 56(84) bytes of data.
> > 64 bytes from 192.168.50.254: icmp_seq=1 ttl=64 time=0.554 ms
> > 
> > --- 192.168.50.254 ping statistics ---
> > 1 packets transmitted, 1 received, 0% packet loss, time 0ms
> > rtt min/avg/max/mdev = 0.554/0.554/0.554/0.000 ms
> 
> Ok, so we've ruled out a time sync issue.  And you have valid kerberos 
> tickets on the appliance.  And we know the Node at .254 is running since 
> you can ping it.
> 
> The next question is, does the Node have a valid kerberos ticket?  Can you 
> give me the /var/log/ovirt.log file from the .254 Node?  And do you have 
> an /etc/libvirt/krb5.tab file on the Node?

i haven't file /etc/libvirt/krb5.tab on all nodes
where i can find  valid kerberos ticket ?

> 
> Perry
> 
+ local_install 0 '' ' console=ttyS0,115200n8 console=tty0'
+ local local_os=0
+ local target=
+ local 'bootparams= console=ttyS0,115200n8 console=tty0'
+ local disk
+ local part
+ local live_part
+ local live_disk
+ local live_dev=/dev/live
+ '[' '!' -e /dev/live ']'
+ live_dev=/dev/loop0
+ live_part=/dev/loop0
+ live_disk=
++ readlink -e /dev/disk/by-label/OVIRT
+ local ovirt_part=
+ local ovirt_disk=
+ '[' '' = '' ']'
+ ovirt_disk=
+ '[' -z '' ']'
+ '[' -z '' ']'
+ return 1
+ set +x
Configuring network Using interface eth0
waiting for link... 1 seconds.
Sending request for IP information through eth0
Listening on LPF/eth0/00:30:48:65:3d:b4
Sending on   LPF/eth0/00:30:48:65:3d:b4
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPOFFER from 10.20.4.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 10.20.4.1
bound to 192.168.50.254 -- renewal in 9640 seconds.
Interface brought up with 192.168.50.254/24
Applying default configuration to eth0 and ovirtbr0
Applying default configuration to eth1 and ovirtbr1
Default config applied
  No volume groups found
mount: you must specify the filesystem type
mount: you must specify the filesystem type
umount: /tmp/tmp.fosBw2HRlZ: not mounted
skipping Kerberos configuration
skipping ovirt-awake, oVirt identify service not available
skipping collectd configuration, collectd service not available
skipping libvirt-qpid configuration, could not find 
mount: you must specify the filesystem type
mount: you must specify the filesystem type
store config:mount: can't find /tmp/tmp.2mlDaI5zOX in /etc/fstab or /etc/mtab
 /etc/ssh/ssh_host_dsa_key /etc/ssh/ssh_host_dsa_key.pub /etc/ssh/ssh_host_key /etc/ssh/ssh_host_key.pub /etc/ssh/ssh_host_rsa_key /etc/ssh/ssh_host_rsa_key.pub
umount: /tmp/tmp.2mlDaI5zOX: not mounted
skipping ovirt-identify-node, oVirt registration service not available

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]