[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Ovirt-devel] Build fails due to missing ovirt-node-recipe.ks



On Sat, Jul 03, 2010 at 12:17:24AM +1000, Justin Clacherty wrote:
> On 07/02/2010 11:45 PM, Justin Clacherty wrote:
> >On 07/02/2010 09:40 PM, Darryl L. Pierce wrote:
> >>
> >>I'm going to fix a few things there, yeah. :)
> >
> >I'm just starting from scratch using the new build instructions.
> >The instructions clone the node and server repositories, should I
> >be switching to the next branch as well?
> 
> It appears I'm cursed :-)
> 
> Building/Installing from the updated build instructions all goes
> well up to building the node iso.  Now, in building the node iso it
> says to install ovirt-node-tools from the previous step, that works
> fine.  Then go to node/recipe and run "make ovirt-node-image.iso".
> This fails complaining about missing kickstart files (see below).
> 
> However, the missing file (repos.ks) was installed to
> /usr/share/ovirt-node-tools so I copied it from there and tried the
> build.  It's runs a bit longer then fails because it is unable to
> find the ovirt-node package that was built in the previous step.
> Executing "yum list ovirt-node" shows that the newly built package
> is in the ovirt-local repository which is in the ovirt-cache
> directory pointed to by the environment variable.

I'll doublecheck the Makefile, but it should be generating repos.ks
automatically when you call the ovirt-node-image.iso target, since it's
a dependency. In the meantime try:

make
make ovirt-node-image.iso

since the repos.ks is the default target.

-- 
Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
Delivering value year after year.
Red Hat ranks #1 in value among software vendors.
http://www.redhat.com/promo/vendor/

Attachment: pgpMSzNXHPk4q.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]