[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Lilo help



--- Jim Morton <jbmorton bellatlantic net> wrote:
> I have a system w the following drives:
> hda	10.5 Gig w RH6.1 boots fine from lilo
> hdb	1.8 Gig formatted by Win98, empty, Fat32
> hdc	2.5 Gig w Win98 installed
> hdd	CD-Rom
> 
> At the Lilo prompt I enter 'dos' and and get 
> Loading dos 
> Invalid system disk 
> Replace the disk and press any key

This sounds like a bios problem. Only recent bioses are capable of booting from
the 3rd and fourth drive, or cdrom.


> 
> If I switch the ide cables between hda and hdc the system boots right up
> into Windows. What am I doing wrong? Why can't Lilo boot my Windows drive?
> 

see above - in DOS you switched E: and F: to C: and D: which worked.

> This is my lilo.conf
> # more lilo.conf
> boot = /dev/hda
> timeout = 50
> prompt
>   default = linux
>   vga = normal

not here >   read-only

> map=/boot/map
> install=/boot/boot.b

> image = /boot/vmlinuz-2.2.12-20
>   label = linux
>   initrd = /boot/initrd-2.2.12-20.img
>   root = /dev/hda9
    read-only
> other = /dev/hdc1
>   label = dos
>   table = /dev/hdc1
    
> 
> On the line 'other' and 'table' I have tried /dev/hda, /dev/hda1, /dev/hdc,
> and /dev/hdc1 and various combinations. 
> I've read quite a few Lilo Howto's and they all seem to want to boot your
> option of os from the same hd. Nowhere can I find info on booting to
> different drives. Is it possible?
> 
> Thanks in advance
> Jim Morton
> 
> 
> -- 
> To unsubscribe: mail redhat-install-list-request redhat com with
> "unsubscribe" as the Subject.
> 


=====
Mick Mearns - Puyallup, Washington, U.S.A

Linux, Formula One, Pink Floyd, Puccini fan

__________________________________________________
Do You Yahoo!?
Send instant messages & get email alerts with Yahoo! Messenger.
http://im.yahoo.com/



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]