[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Nothing works - Apache doesn't work in 6.2



Probably the best bet is not to use linuxconf for all your config needs
The apache site is pretty good in it's explaination on the configuation
of apache. Also there are some good Apache config tools. One is
commanche. You could either do a search at Linuxburg or Freshmeat.


> -----Original Message-----
> From: EdHoo [mailto:edhoo hotmail com]
> Sent: Thursday, 25 May 2000 15:18
> To: redhat-install-list redhat com
> Subject: Re: Nothing works - Apache doesn't work in 6.2
> 
> 
> There is your problem.
> 
> > <Files ~>
> > AllowOverride AuthConfig FileInfo Indexes Limit Options
> >     Order allow,deny
> >     Deny from all
> > </Files>
> 
> Try
> 
> <Files ~ "^\.ht">
> AllowOverride AuthConfig FileInfo Indexes Limit Options
>     Order allow,deny
>     Deny from all
> </Files>
> 
> I suspect linuxconf is messing around with the settings (or 
> it could be an
> installation script), so get the original file from the RPM 
> and work the
> parameters by hand.  Make backup copies of the file as you 
> work it out.  The
> original file is also very well commented and follows a logic 
> progression,
> once you edit it with linuxconf you sometimes lose part of that.
> 
> BTW: How do we report this little issues?
> 
> Ed
> 
> ----- Original Message -----
> From: "Derek Ryan White" <d-man97 yahoo com>
> To: <redhat-install-list redhat com>
> Sent: Tuesday, May 23, 2000 10:20 PM
> Subject: Nothing works - Apache doesn't work in 6.2
> 
> 
> > Here is some preview reading.  This is in my error_log several
> > times:
> >
> > [Tue May 23 19:44:35 2000] [crit] (98)Address already in use:
> > make_sock: could not bind to port 80
> > [Tue May 23 19:45:09 2000] [error] [client 192.168.0.2] client
> > denied by server configuration: /home/httpd/html
> > [Tue May 23 19:48:14 2000] [error] [client 127.0.0.1] client
> > denied by server configuration: /home/httpd/html
> >
> > 192.168.0.2 is my LAN IP address and I hope I don't have to say
> > what the other one is.  This may explain the [error] messages
> > better to you guys; here is the part of my httpd.conf by "#
> > Controls who can get stuff from this server." (N.B. I have cut
> > out the stupid comments):
> >
> > <Directory /"/home/httpd/html/">
> > AllowOverride AuthConfig FileInfo Indexes Limit Options
> >     Order allow,deny
> >     Allow from all
> > </Directory>
> > <Files ~>
> > AllowOverride AuthConfig FileInfo Indexes Limit Options
> >     Order allow,deny
> >     Deny from all
> > </Files>
> > <Directory /icons/"/home/httpd/icons/">
> > AllowOverride AuthConfig FileInfo Indexes Limit Options
> >     Order allow,deny
> >     Allow from all
> > </Directory>
> > <Directory /cgi-bin/"/home/httpd/cgi-bin/">
> > Options ExecCgi
> > AllowOverride AuthConfig FileInfo Indexes Limit Options
> >     Order allow,deny
> >     Allow from all
> > </Directory>
> >
> > I have tried the <Directory directory> with a trailing / and
> > without one and this gives me no error when running "httpd", but
> > it still does give me the 403 message when I try to connect.  If
> > I change it to something like <Directory / "/home/httpd/html/">
> > (space between the / and the "/home...), I get this error
> > "Multiple <Directory> arguments not (yet) supported.
> >   I changed the user to www and in Linuxconf made www's home
> > directory /home/httpd then Linuxconf recursively changed the
> > ownership of those files to user www, then I changed the user
> > and group in httpd.conf.  I really do not believe the problem is
> > with this because it does the same thing with user nobody and
> > the file permissions are all correct.  Directories are set to
> > 0755 and files are set to 0744, also I can access and read, the
> > files logged in a just a regular user.
> > If anyone has a working httpd.conf file, could you please send
> > it directly to me? You can use xxx for anything that changes
> > like the IP and stuff if you do not want me to see it.
> >
> > If someone wants to help me more I will send you my httpd.conf
> > file.
> >
> > LOST,
> > Derek
> >
> >
> > Yehuda Feinsilber wrote:
> > >
> > > Derek,
> > > It is NOT a permission problem just a slight error in httpd.conf.
> > >
> > > Open /etc/httpd/conf/httpd.conf.
> > > Find  The line "# Controls who can get stuff from this server."
> > > Edit the next line to be:
> > > <Directory /"/home/httpd/html">
> > > Do the same for .....httpd/icons>
> > > Do the same for .....httpd/cgi-bin>
> > >
> > > Yehuda Feinsilber
> 
> 
> -- 
> To unsubscribe: mail redhat-install-list-request redhat com with
> "unsubscribe" as the Subject.
> 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]