[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

httpd-2.0.45-14 starts, but always dies shortly after



I did a search in the bug tracking database and did not find a reference
to this issue.

'/etc/rc.d/init.d/httpd start' and /var/log/messages report that
httpd-2.0.45-14 starts successfully:

    Jul 22 10:54:42 mark httpd: httpd startup succeeded

The process sticks around for a few ticks (long enough to catch it
once or twice with 'ps -ef' if I am quick enough) and then dies an
abrupt death. Using 'gdb /usr/sbin/httpd' 'set args -X' 'run' I was
able to determine that:

    Program received signal SIGSEGV, Segmentation fault.
    [Switching to Thread -1084365088 (LWP 3148)]
    0x00000000 in ?? ()
    (gdb) where
    #0  0x00000000 in ?? ()
    #1  0x00fc8f50 in KRB5_AUTHENT_it () from /lib/libcrypto.so.4

I tried replacing openssl-0.9.7a-16.i686 with openssl-0.9.7a-16.i386,
and at around the same spot I received (debug trace lost) an invalid
instruction trap. After restoring openssl-0.9.7a-16.i686, the above
error returned.

My host platform is an intel P3. I am currently running httpd-2.0.47
(built from the tar file at apache.org) in the interim.

Cheers,
mark

-- 
mark mielke cc/markm ncf ca/markm nortelnetworks com __________________________
.  .  _  ._  . .   .__    .  . ._. .__ .   . . .__  | Neighbourhood Coder
|\/| |_| |_| |/    |_     |\/|  |  |_  |   |/  |_   | 
|  | | | | \ | \   |__ .  |  | .|. |__ |__ | \ |__  | Ottawa, Ontario, Canada

  One ring to rule them all, one ring to find them, one ring to bring them all
                       and in the darkness bind them...

                           http://mark.mielke.cc/




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]