[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: New redhat-config-packages feedback thread



Nick Marsh wrote :

> I like the idea behind the new redhat-config-packages. However, I liked
> the old UI better (it seemed less redundant). IMHO, its better to be able
> to add or remove packages just by checking or unchecking them rather than
> having to be on the "add side" or "remove side" of the application.

I don't really mind it, but it's definitely still rough around the edges.
I've tried to uninstall packages to see, and as some were required by
firstboot, I got a "Packages not found" and the packages that couldn't be
removed because of dependencies were listed as "Unlocatable packages".
Probably a generic dialog, but that shouldn't happen as it's really
misleading.

Also none of the menus except "Quit" and switching in "View" work.

I also got weird stuff like "0 of 2 installed" for ftp server, although I
do have vsftpd installed, which causes a problem when I try to install it:

selecting already installed package vsftpd
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/AddDialog.py", line 338, in
addDialogInstallButtonClicked
    iter = self.model.iter_children(self.optional_iter)
AttributeError: 'AddDialog' object has no attribute 'optional_iter'

Then, anyway, I seem to have a big clash that prevents anything from
working, possibly due to epoch handling in xmms(?):

* depcheck: package nautilus-cd-burner needs cdrecord (not provided)
* depcheck: package redhat-config-soundcard needs sox (not provided)
* depcheck: package xmms-crossfade needs libxmms.so.1 (not provided)
* depcheck: package gkrellm-plugins-media needs libxmms.so.1 (not provided)
* depcheck: package flac-xmms needs libxmms.so.1 (not provided)
* depcheck: package xmms-alsa needs libxmms.so.1 (not provided)
* depcheck: package xmms-mp3 needs xmms = 1:1.2.7 (not provided)
* depcheck: package xmms-crossfade needs xmms >= 1.0.0 (not provided)
* depcheck: package gkrellm-plugins-media needs xmms (not provided)
* depcheck: package flac-xmms needs xmms >= 0.9.5.1 (not provided)
* depcheck: package xmms-xosd needs xmms (not provided)
* depcheck: package xmms-devel needs xmms = 1:1.2.7 (not provided)
* depcheck: package xmms-alsa needs xmms >= 1.2.5 (not provided)
* depcheck: package alsaplayer needs libmikmod.so.2 (not provided)
* depcheck: package gstreamer-plugins needs libmikmod.so.2 (not provided)
('cdrecord', None, 0)
('sox', None, 0)
('libxmms.so.1', None, 0)
('libxmms.so.1', None, 0)
('libxmms.so.1', None, 0)
('libxmms.so.1', None, 0)
('xmms', '1:1.2.7', 8)
('xmms', '1.0.0', 12)
('xmms', None, 0)
('xmms', '0.9.5.1', 12)
('xmms', None, 0)
('xmms', '1:1.2.7', 8)
('xmms', '1.2.5', 12)
('libmikmod.so.2', None, 0)
('libmikmod.so.2', None, 0)

I guess I could file bug reports, but it would be so many that I'm not even
sure it would help if what the application needs is still massive low-level
work.

Matthias

-- 
Clean custom Red Hat Linux rpm packages : http://freshrpms.net/
Raw Hide 20030718 running Linux kernel 2.4.20-20.1.2013.nptl
Load : 0.08 0.32 0.39




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]