[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: CDROM confusion



This problem sounds awfully familiar. It sounds like phoebe is back!

I left the extra, but not correct links in the file. I accessed the correct link to mount the device.

Somehow, it disappeared for me. I think that I updated some stuff to test out the 2.5 kernel.


[jim cornette jim]$ cat /etc/fstab ....snip... (This is from RH9) /dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0 /dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

[jim cornette jim]$ ls -la /dev/cd*
lrwxrwxrwx 1 root root 9 Jul 18 17:25 /dev/cdrom -> /dev/scd0
lrwxrwxrwx 1 root root 9 Jul 18 17:25 /dev/cdrom1 -> /dev/scd1
lrwxrwxrwx 1 root root 8 Jul 30 18:42 /dev/cdwriter -> /dev/sg1


-----------------------

[jim cornette jim]$ cat /severn/etc/fstab
....snip.... (This is from upgrading from RHL 7.3 to Severn)
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0


[jim cornette jim]$ ls -la /severn/dev/cd*
lrwxrwxrwx 1 root root 8 Mar 10 21:54 /severn/dev/cdrom -> /dev/hdc
lrwxrwxrwx 1 root root 9 Mar 10 21:54 /severn/dev/cdrom1 -> /dev/scd0
lrwxrwxrwx 1 root root 8 Jul 30 18:36 /severn/dev/cdwriter -> /dev/sg0


good luck!!!

Jim


Gerry Tool wrote:


I am going nuts trying to figure out how to get kudzu to stop trying to mount "extra" cdrom drives. I have two drives, a cdrw on hdc and a dvd player on hdd. I have added hdc=ide-scsi hdd=ide-scsi to my kernel line in grub.conf. I have created links /dev/cdrom linked to /dev/scd0 and /dev/cdrom1 linked to /dev/scd1.

I have changed /etc/fstab to read

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,user,ro 0 0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,user,ro 0 0


trying not to use kudzu for the cdrom drives.

When I reboot, kudzu insists on creating new links /dev/cdrom2 to /dev/hdc and /dev/cdrom3 to /dev/hdd, and adding lines as follows to /etc/fstab.

/dev/cdrom2 /mnt/cdrom2 udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom3 /mnt/cdrom3 udf,iso9660 noauto,owner,kudzu,ro 0 0


This all worked fine when I set it up this way in RHL8.0 and RHL9.

How can I resolve this?

Thanks in advance.

Gerry





--
Rhl-beta-list mailing list
Rhl-beta-list redhat com
http://www.redhat.com/mailman/listinfo/rhl-beta-list



--
I wonder if I ought to tell them about my PREVIOUS LIFE as a COMPLETE
STRANGER?





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]