[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 2.6.0- test2, getting sound to work?



On Thu, 31 Jul 2003 08:28:04 -0700, you wrote:

I had to reboot my computer to do something else and when I booted
into Severn again sound was working, although there still appears to
be problems.

>2.6 defaults to ALSA which is supposed to have hooks for all the older OSS stuff. However, ALSA mutes most of the channels by default.
>
>Go to a terminal and type alsamixer. Move through the channels with the left and right cursor keys and hit the spacebar to unmute the channels that you want open. ESC to save and exit. Should work after that.

No alsamixer.  Could see nothing alsa related in severn or rawhide so
I went to freshrpms.net and grabbed alsa-utils which provided me with
alsamixer which results in this:

[root CPE00a0cc51b5c5-CM root]# alsamixer
alsamixer: function snd_ctl_open failed for default: No such device

The following can be found in /var/log/messages:

Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: Creative EMU10K1 PCI Audio
Driver, version 0.20a, 06:21:18 Jul 30 2003
Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: PCI: Found IRQ 11 for
device 0000:00:11.0
Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: PCI: Sharing IRQ 11 with
0000:00:07.2
Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: PCI: Sharing IRQ 11 with
0000:00:09.0
Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: emu10k1: EMU10K1 rev 5
model 0x20 found, IO at 0xe000-0xe01f, IRQ 11
Jul 31 12:48:34 CPE00a0cc51b5c5-CM kernel: ac97_codec: AC97  codec,
id: TRA35 (TriTech TR A5)
Jul 31 12:48:35 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_0_3 not found. 
Jul 31 12:50:08 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
char_major_116 not found. 
Jul 31 12:50:51 CPE00a0cc51b5c5-CM last message repeated 6 times
Jul 31 12:50:53 CPE00a0cc51b5c5-CM last message repeated 11 times
Jul 31 12:52:20 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_1 not found. 
Jul 31 12:52:20 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_1_0 not found. 
Jul 31 12:52:20 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_2 not found. 
Jul 31 12:52:20 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_2_3 not found. 
Jul 31 12:52:20 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_3 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_3_3 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_1 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_1_0 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_2 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_2_3 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_3 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_3_3 not found. 
Jul 31 12:52:21 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_2 not found. 
Jul 31 12:52:22 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_2_3 not found. 
Jul 31 12:52:22 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_slot_3 not found. 
Jul 31 12:52:22 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
sound_service_3_3 not found. 
Jul 31 12:52:22 CPE00a0cc51b5c5-CM modprobe: FATAL: Module synth0 not
found. 
Jul 31 13:26:55 CPE00a0cc51b5c5-CM modprobe: FATAL: Module
char_major_116 not found.

My modprobe.conf and modules conf files are:
/etc/modprobe.conf:
include /etc/modprobe.conf.dist
alias parport_lowlevel parport_pc
alias eth0 tulip
alias eth1 tulip
alias scsi_hostadapter sym53c8xx
alias sound-slot-0 emu10k1
alias usb-controller usb-uhci
alias char-major-195 nvidia
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && {
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }
remove sound-slot-0 { /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :; }; /sbin/modprobe -r --ignore-remove
sound-slot-0

/etc/modules.conf:
alias parport_lowlevel parport_pc
alias eth0 tulip
alias eth1 tulip
alias scsi_hostadapter sym53c8xx
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
>/dev/null 2>&1 || :
alias usb-controller usb-uhci
alias char-major-195 nvidia




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]