[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can we have g++/libstdc 32 packages



On Thu, Jul 31, 2003 at 01:13:03PM -0400, Joel Young wrote:
> 
> There was an error in the abi for g++3.2x .  By default the fixed
> abi isn't used in g++3.3 to ensure the advertised abi compatibility
> across g++ 2.2 and 2.3, but the fixed abi can be selected with
> -fabi-version=0  .  This fixes some issues with ublas in boost.
> 
> Since gcc 3.3 is being used exclusively in redhat severn, could this
> compiler flag be used by default to ensure a (more) correct ABI
> is used for C++?

No, it cannot. We want to be:
a) binary compatible with other 3.3.x compilers
b) binary compatible with 3.2.x
In addition to this -fabi-version=0 is a moving target, it changes quite
often and there are several thing which are still going to change
(and not just things which happen rarely, but things which will matter
in almost every single C++ object file).

	Jakub




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]