[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Any ideas on fixing some problems?



The %pre and %post scriptlet problems are selinux-related.

As root:

sestatus

If current mode is enforcing, run "setenforce 0" then try the yum update again.

Dave

Paul wrote:

Hi,

I'm trying to do an update and am getting the following

1. yum -y --exclude=swig update

Traceback (most recent call last):
 File "/usr/bin/yum", line 6, in ?
   import yummain
 File "/usr/share/yum-cli/yummain.py", line 23, in ?
   import yum
 File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 21, in ?
   import rpm
ImportError: /usr/lib/librpm-4.3.so: undefined symbol: rpm_execcon

2. rpm -ihv kernel-2*

error: %pre(kernel-2.6.9-1.1020_FC4.i686) scriptlet failed, exit status
0
error:   install: %pre scriptlet failed (2), skipping
kernel-2.6.9-1.1020_FC4

Something somewhere is jiggered, but I'm at a loss as to what. I've
installed rpm, yum and python manually from the development branch on
the download.fedora ftp area and they seemed to go in fine.

TTFN

Paul






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]