[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: selinux-policy-strict-2.2.38-1.fc5@noarch failed



On Mon, May 15, 2006 at 09:26:32 -0400,
  Daniel J Walsh <dwalsh redhat com> wrote:
> Neal Becker wrote:
> >Output from selinux-policy-strict-2 2 38-1 fc5 noarch:
> >libsepol.scope_copy_callback: authlogin: Duplicate declaration in module: 
> >type/attribute system_chkpwd_t
> >libsemanage.semanage_link_sandbox: Link packages failed
> >semodule:  Failed!
> >
> >
> >  
> Seems to be the only way to get rid of this is too:
> 
> rpm -e selinux-policy-strict
> rm -rf /usr/share/selinux/strict /etc/selinux/strict
> rpm -Uhv selinux-policy-strict-2.2.38-1.fc5
> 
> This was caused by a bad package that went out in the first few weeks of 
> the release. 

This ended up being a little trickier than above, but that was good enough
advice to help me solve the problem. I will update and close my bugzilla
ticket on this issue.
In my case selinux-policy-strict-2.2.34-3.fc5 was still showing up in the rpm
database even though it had been superceded. I needed to erase it twice to get
it to go away.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]