[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Synaptic and apt problems...



On Sat, 2006-05-27 at 13:27 -0600, Kim Lux wrote:
> On Sat, 2006-05-27 at 11:58 +0300, Panu Matilainen wrote:
> > What does 'rpm -q apt synaptic' say?
> > 
> >         - Panu -
> > 
> 
> $ rpm -q synaptic
> synaptic-0.57.2-1.fc4
> 
> $ rpm -q apt
> apt-0.5.15lorg3.1-5.fc4
> 
> 
> I've tried several version of synaptic, all with the same result. 

Synaptic needs some patches to work with repomd and you need to have
synaptic built against the very exact version of apt (due to apt soname
not having changed when it really should have), eg:
http://download.fedora.redhat.com/pub/fedora/linux/extras/4/i386/synaptic-0.57.2-5.0.fc4.i386.rpm

Also make sure you don't have any locally installed libapt-pkg or synaptic versions lying
around. If the above version still behaves strangely it starts sounding like a real bug.

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]